]> git.donarmstrong.com Git - deb_pkgs/libapache-gallery-perl.git/blobdiff - debian/rules
uuencode text/html and text/text icons
[deb_pkgs/libapache-gallery-perl.git] / debian / rules
index 9a5efd03d69c7f33c20e658a5ee45e78d9c6245a..f8d4830559d7dacc99eb80b97c03e4f06ac78e71 100755 (executable)
@@ -52,13 +52,17 @@ clean:
        -$(MAKE) clean
        if [ -e Makefile ]; then $(MAKE) -i distclean; fi
        dh_clean arrange-stamp binary-stamp binary-arch-stamp binary-indep-stamp build-stamp config-stamp install-stamp
+       rm -f htdocs/text-text.png htdocs/text-html.png
        rm -rf debian/libapache-gallery-perl
        rm -rf Makefile.old
 
 config: config-stamp
 config-stamp:
        dh_testdir
-       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       $(PERL) Makefile.PL INSTALLDIRS=vendor  
+       # deal with uuencoded icons
+       uudecode -o htdocs/text-txt.png debian/text-text.png.uuencode
+       uudecode -o htdocs/text-html.png debian/text-html.png.uuencode
        touch config-stamp
 
 install: install-stamp
@@ -66,7 +70,6 @@ install-stamp: build
        dh_testdir
        dh_clean -k
        dh_installdirs
-       
        $(MAKE)
        $(MAKE) install PREFIX=$(CURDIR)/debian/libapache-gallery-perl/usr
        cp -r $(CURDIR)/templates/* $(CURDIR)/debian/libapache-gallery-perl/usr/share/libapache-gallery-perl/templates