I read that ppa:cassou/emacs is deprecated
authorJohn Kitchin <jkitchin@andrew.cmu.edu>
Tue, 21 Apr 2015 00:07:39 +0000 (20:07 -0400)
committerJohn Kitchin <jkitchin@andrew.cmu.edu>
Tue, 21 Apr 2015 00:07:39 +0000 (20:07 -0400)
here: http://oremacs.com/2015/03/30/elisp-ert-travis/

this commit makes my travis setup more similar to this one.

.travis.yml

index 1f94d83..d51906f 100644 (file)
@@ -1,20 +1,20 @@
 language: emacs-lisp
+
+env:
+  matrix:
+    - emacs=emacs-snapshot
+
 before_install:
-  # PPA for stable Emacs packages
-  - sudo add-apt-repository -y ppa:cassou/emacs
-  # PPA for Emacs nightlies
   - sudo add-apt-repository -y ppa:ubuntu-elisp/ppa
-  # Update and install the Emacs for our environment
   - sudo apt-get update -qq
-  - sudo apt-get install -qq -yy ${EMACS}-nox ${EMACS}-el
+  - sudo apt-get install -qq $emacs
+
   # Install cask dependencies
   - curl -fsSLo /tmp/cask-master.zip https://github.com/cask/cask/archive/master.zip
   - sudo unzip -qq -d /opt /tmp/cask-master.zip
   - sudo ln -sf /opt/cask-master/bin/cask /usr/local/bin/cask
   - cask
-env:
-#  - EMACS=emacs24
-  - EMACS=emacs-snapshot
+
 script:
   - emacs --version
   - make test
\ No newline at end of file