]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Also for stats report which repo and which job number use our setup
[neurodebian.git] / Makefile
index b90bdf7ccf5f1e42dafbd04b7332ef70729c6810..3a97d7c090b26a7c7197ab9055d8ca32cf31f682 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,8 +4,8 @@ WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
-BIGMESS_OPTS = -c neurodebian_repo.cfg
-BIGMESS_CMD = PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess
+BIGMESS_OPTS = -c neurodebian.cfg
+BIGMESS_CMD = PYTHONPATH=.:3rd/bigmess:$(PYTHONPATH) 3rd/bigmess/bin/bigmess
 BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
 
 # Lentghy one due to updatedb
@@ -13,6 +13,12 @@ all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
 refresh: upload-website-stamp mirmon
 
+website-build-depends:
+       : # Python modules
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian python-html5lib
+       : # JavaScripts
+       sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
+
 
 pics:
        $(MAKE) -C artwork
@@ -20,7 +26,7 @@ pics:
 
 html: pics source
        rsync -rvlhpt sphinx/ build/src
-       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png *-logo_h50.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
@@ -42,25 +48,33 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp: 
+source-stamp:
        mkdir -p build/src/pkgs/
        mkdir -p build/src/lists/
+       mkdir -p build/src/_static/
        mkdir -p build/src/pkglists/
        $(BIGMESS) mkpkgs  -d build/src/pkgs/
        $(BIGMESS) mkaptcfgs -d build/src/lists/
+       $(BIGMESS) mkmirrorsstat -d build/src
        $(BIGMESS) mkrepocfg > build/src/sources_lists
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
+       cp 3rd/nvd3/*.min.js build/src/_static/
+       cp 3rd/nvd3/lib/d3*.min.js build/src/_static/
+       cp 3rd/nvd3/src/nv*.css build/src/_static/
        touch $@
 
+cachefiles:
+       $(BIGMESS) cachefiles -f
 
-updatedb:
-       $(BIGMESS) cachefiles
+updatedb: cachefiles
        $(BIGMESS) updatedb
+       -rm source-stamp
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=debian-custom --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --chmod=Dg+s,g+rw tools/neurodebian-travis.sh $(WWW_UPLOAD_URI)/_files/
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp
 
@@ -77,5 +91,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon