]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Also for stats report which repo and which job number use our setup
[neurodebian.git] / Makefile
index 3f1399860d378b1078588606439a33d668fce125..3a97d7c090b26a7c7197ab9055d8ca32cf31f682 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ refresh: upload-website-stamp mirmon
 
 website-build-depends:
        : # Python modules
-       sudo apt-get install python-sphinx python-argparse python-xdg python-debian
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian python-html5lib
        : # JavaScripts
        sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
 
@@ -26,7 +26,7 @@ pics:
 
 html: pics source
        rsync -rvlhpt sphinx/ build/src
-       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png *-logo_h50.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
@@ -51,12 +51,16 @@ source: source-stamp
 source-stamp:
        mkdir -p build/src/pkgs/
        mkdir -p build/src/lists/
+       mkdir -p build/src/_static/
        mkdir -p build/src/pkglists/
        $(BIGMESS) mkpkgs  -d build/src/pkgs/
        $(BIGMESS) mkaptcfgs -d build/src/lists/
        $(BIGMESS) mkmirrorsstat -d build/src
        $(BIGMESS) mkrepocfg > build/src/sources_lists
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
+       cp 3rd/nvd3/*.min.js build/src/_static/
+       cp 3rd/nvd3/lib/d3*.min.js build/src/_static/
+       cp 3rd/nvd3/src/nv*.css build/src/_static/
        touch $@
 
 cachefiles:
@@ -68,8 +72,9 @@ updatedb: cachefiles
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=debian-custom --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --chmod=Dg+s,g+rw tools/neurodebian-travis.sh $(WWW_UPLOAD_URI)/_files/
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp