]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Makefile: update for new org function names in org 8.2
authorDavid Bremner <bremner@debian.org>
Thu, 13 Nov 2014 21:36:35 +0000 (22:36 +0100)
committerBill Allombert <Bill.Allombert@math.u-bordeaux1.fr>
Sat, 15 Nov 2014 09:59:58 +0000 (10:59 +0100)
Emacs 24.4 includes an updated org-mode, which changes the export framework quite a lot.

This patch also stops sending errors and warnings to /dev/null, in
order to help with debugging.

Makefile

index a10b93d7092ebb6e22e33e3023d94b892f7422c4..4b7f62dbb6b7f12189c7247715a967d975c0b8a8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -5,13 +5,13 @@ menu-policy.sgml: version.ent
 perl-policy.sgml: version.ent
 
 %.txt: %.org
-       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
-          --funcall org-export-as-ascii >/dev/null 2>&1
+       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+          --funcall org-ascii-export-to-ascii
        test "$@" != "README.txt"  ||                            \
            perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
-          --funcall org-export-as-html-batch >/dev/null 2>&1
+          --funcall org-html-export-to-html
 
 %.validate: %
        nsgmls -wall -gues $<