]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debconf_spec/Makefile
do .gz in here, quieten tidy in itself
[debian/debian-policy.git] / debconf_spec / Makefile
index 454168637465fb5af6a5f70176ccafc63411a645..e44ac081e69d553fa409e1feab6e13cdfc10a559 100644 (file)
@@ -1,13 +1,16 @@
-all: debconf_specification.txt debconf_specification.html
+all: debconf_specification.txt.gz debconf_specification.html
 
 %.html: %.xml html.dsl
        jade -V nochunks -t sgml -d html.dsl \
                /usr/lib/sgml/declaration/xml.dcl $< > $@
-       -tidy -i -m -f /dev/null $@
+       -tidy -q -i -m -f /dev/null $@
 
 %.txt: %.html
        links -dump $< | perl -pe 's/[\r\0]//g' > $@
 
+%.txt.gz: %.txt
+       gzip -cf9 $< > $@
+
 clean:
        rm -f *.css *.html *.txt *.txt.gz