]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debconf_spec/Makefile
Fix FTBFS and migrate to openjade/opensp
[debian/debian-policy.git] / debconf_spec / Makefile
index 59b0dd7cb0617d725d0b3910aa1a54eaf7a56e7a..cdfd135d50d75802d5443a434e6859f13c1ac4cf 100644 (file)
@@ -1,12 +1,17 @@
-all: debconf_specification.txt debconf_specification.html
+all: debconf_specification.txt.gz debconf_specification.html
 
 %.html: %.xml html.dsl
-       jade -V nochunks -t sgml -d html.dsl \
-               /usr/lib/sgml/declaration/xml.dcl $< > $@
-       -tidy -i -m -f /dev/null $@
+       openjade -V nochunks -t sgml -d html.dsl \
+               /usr/share/xml/declaration/xml.dcl $< > $@
+       -tidy -q -i -m -f /dev/null $@
 
 %.txt: %.html
        links -dump $< | perl -pe 's/[\r\0]//g' > $@
 
+%.txt.gz: %.txt
+       gzip -ncf9 $< > $@
+
 clean:
-       rm -f *.css *.html *.txt
+       rm -f *.css *.html *.txt *.txt.gz
+
+.DELETE_ON_ERROR: