]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - copyright-format/Makefile
Import DEP-5 as a document called copyright-format.
[debian/debian-policy.git] / copyright-format / Makefile
diff --git a/copyright-format/Makefile b/copyright-format/Makefile
new file mode 100644 (file)
index 0000000..27d8f5b
--- /dev/null
@@ -0,0 +1,17 @@
+all: copyright-format.txt.gz copyright-format.html
+
+%.html: %.xml html.dsl
+       jade -V nochunks -t sgml -d html.dsl \
+               /usr/share/xml/declaration/xml.dcl $< > $@
+       -tidy -q -i -m -f /dev/null $@
+
+%.txt: %.html
+       links -dump $< | perl -pe 's/[\r\0]//g' > $@
+
+%.txt.gz: %.txt
+       gzip -cf9 $< > $@
+
+clean:
+       rm -f *.css *.html *.txt *.txt.gz
+
+.DELETE_ON_ERROR: