]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - autopkgtest/Makefile
autopkgtest: new specification for autopkgtest/DEP-8 tests
[debian/debian-policy.git] / autopkgtest / Makefile
diff --git a/autopkgtest/Makefile b/autopkgtest/Makefile
new file mode 100644 (file)
index 0000000..8ec4719
--- /dev/null
@@ -0,0 +1,13 @@
+all: autopkgtest.html autopkgtest.txt.gz
+
+autopkgtest.html: autopkgtest.md.expanded
+       markdown $< > $@
+
+autopkgtest.txt.gz: autopkgtest.md.expanded
+       gzip -ncf9 $< > $@
+
+autopkgtest.md.expanded: autopkgtest.md version.txt
+       cat $^ > $@
+
+clean:
+       rm -f autopkgtest.html autopkgtest.txt.gz $(wildcard *.expanded)