]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
autopkgtest.desc: replace reference to packages-tests by autopkgtest
[debian/debian-policy.git] / Makefile
index 1d0852e5141aa6722af1acaeadf14ef2298acaf6..aa5408f8ee6e1985c8f472fe263882768cfb2eb8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,16 @@ include debian/rules
 
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
-mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
+
+%.txt: %.org
+       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+          --funcall org-ascii-export-to-ascii
+       test "$@" != "README.txt"  ||                            \
+           perl -pli -e 's,./Process.org,Process.txt,g' $@
+%.html: %.org
+       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+          --funcall org-html-export-to-html
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -16,25 +25,35 @@ mime-policy.sgml: version.ent
         rmdir $*-1d.html
 
 %.html.tar.gz: %.html/index.html
-       tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
+       GZIP=-n9 tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
 %.txt: %.sgml
        LANG=C debiandoc2text $<
 
 %.txt.gz: %.txt
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.ps: %.sgml
        LANG=C debiandoc2latexps $<
 
 %.ps.gz: %.ps
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
 
 %.pdf: %.sgml
        LANG=C debiandoc2latexpdf $<
 
 %.pdf.gz: %.pdf
-       gzip -cf9 $< > $@
+       gzip -ncf9 $< > $@
+
+# This is a temporary hack to fold the upgrading-checklist into the Policy
+# HTML directory so that it can be deployed alongside Policy on
+# www.debian.org in a way that lets the cross-document links work properly.
+# The correct solution is to make upgrading-checklist an appendix of Policy,
+# which will probably be done as part of a general conversion to DocBook.
+policy.html.tar.gz:: policy.html/upgrading-checklist.html
+policy.html/upgrading-checklist.html: upgrading-checklist-1.html \
+                                     policy.html/index.html
+       cp -p $< $@
 
 # convenience aliases :)
 html: policy.html/index.html
@@ -45,8 +64,7 @@ pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               libc6-migration.txt \
-               upgrading-checklist.html virtual-package-names-list.txt
+               libc6-migration.txt
              
 .PHONY: distclean
 distclean: