]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
Policy: Obsolete the DM-Upload-Allowed field.
[debian/debian-policy.git] / Makefile
index c3e6b4914d07f62b482fce8d9acbebd39a296189..a10b93d7092ebb6e22e33e3023d94b892f7422c4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,18 +2,16 @@ include debian/rules
 
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
-mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
 
-ifneq (,$(strip $(HAVE_ORG_EMACS)))
 %.txt: %.org
-       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
           --funcall org-export-as-ascii >/dev/null 2>&1
        test "$@" != "README.txt"  ||                            \
            perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
           --funcall org-export-as-html-batch >/dev/null 2>&1
-endif
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -47,6 +45,16 @@ endif
 %.pdf.gz: %.pdf
        gzip -cf9 $< > $@
 
+# This is a temporary hack to fold the upgrading-checklist into the Policy
+# HTML directory so that it can be deployed alongside Policy on
+# www.debian.org in a way that lets the cross-document links work properly.
+# The correct solution is to make upgrading-checklist an appendix of Policy,
+# which will probably be done as part of a general conversion to DocBook.
+policy.html.tar.gz:: policy.html/upgrading-checklist.html
+policy.html/upgrading-checklist.html: upgrading-checklist-1.html \
+                                     policy.html/index.html
+       cp -p $< $@
+
 # convenience aliases :)
 html: policy.html/index.html
 html-1: policy-1.html
@@ -56,8 +64,7 @@ pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               libc6-migration.txt \
-               upgrading-checklist.html virtual-package-names-list.txt
+               libc6-migration.txt
              
 .PHONY: distclean
 distclean: