]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
Do not require initial Debian maintainers be listed in copyright
[debian/debian-policy.git] / Makefile
index d9031ff7e2659ee931c69e6a567a7a366d84b631..9ab6801340181b7fb58dd9a554c02838a26c98c8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,15 +3,16 @@ include debian/rules
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
 mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
 
-ifneq (,$(strip $(HAVE_ORG_EMACS)))
 %.txt: %.org
-       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
           --funcall org-export-as-ascii >/dev/null 2>&1
+       test "$@" != "README.txt"  ||                            \
+           perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
           --funcall org-export-as-html-batch >/dev/null 2>&1
-endif
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -54,8 +55,7 @@ pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               libc6-migration.txt \
-               upgrading-checklist.html virtual-package-names-list.txt
+               libc6-migration.txt
              
 .PHONY: distclean
 distclean: