]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
Document that empty field values are only allowed in debian/control.
[debian/debian-policy.git] / Makefile
index 20433d734b6ab97ea85148164dcd29c386dcb080..4b7f62dbb6b7f12189c7247715a967d975c0b8a8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,18 +2,16 @@ include debian/rules
 
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
-mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
 
-ifneq (,$(strip $(HAVE_ORG_EMACS)))
 %.txt: %.org
-       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
-          --funcall org-export-as-ascii >/dev/null 2>&1
+       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+          --funcall org-ascii-export-to-ascii
        test "$@" != "README.txt"  ||                            \
            perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
-          --funcall org-export-as-html-batch >/dev/null 2>&1
-endif
+          --funcall org-html-export-to-html
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -47,6 +45,16 @@ endif
 %.pdf.gz: %.pdf
        gzip -cf9 $< > $@
 
+# This is a temporary hack to fold the upgrading-checklist into the Policy
+# HTML directory so that it can be deployed alongside Policy on
+# www.debian.org in a way that lets the cross-document links work properly.
+# The correct solution is to make upgrading-checklist an appendix of Policy,
+# which will probably be done as part of a general conversion to DocBook.
+policy.html.tar.gz:: policy.html/upgrading-checklist.html
+policy.html/upgrading-checklist.html: upgrading-checklist-1.html \
+                                     policy.html/index.html
+       cp -p $< $@
+
 # convenience aliases :)
 html: policy.html/index.html
 html-1: policy-1.html