]> git.donarmstrong.com Git - deb_pkgs/spamass-milter.git/commitdiff
* Document that using the -x option requires being in the smmsp group
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Sat, 14 Feb 2009 02:13:32 +0000 (02:13 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Sat, 14 Feb 2009 02:13:32 +0000 (02:13 +0000)
  (closes: #515158)
* Deal with inet:999 sockets (closes: #514749)
  - handle them more sanely in the init script
  - document how to deal with them in README.Debian and
    /etc/spamass-milter/default

debian/README.Debian
debian/changelog
debian/spamass-milter.default
debian/spamass-milter.init

index 16d50d5ac97d1db2812834d783cde4f8be2020d8..ab43cc08ed3efbdf710815a80916679a801dfe7b 100644 (file)
@@ -37,6 +37,13 @@ See http://www.sendmail.com/partner/resources/development/milter_api/installatio
 and http://www.sendmail.org/m4/adding_mailfilters.html#INPUT_MAIL_FILTER
 for more information on milters.
 
+If you are using the alias expansion method, -x, you will need to add
+spamass-milter to the smmsp group using:
+
+ adduser spamass-milter smmsp;
+
+This does not need to be done unless you are using alias expansion.
+
 --------------------------------------------------------------
   Integrating spamass-milter into your postfix installation
 --------------------------------------------------------------
@@ -89,6 +96,14 @@ if you're running postfix.
 RUNAS controls the user which spamass-milter runs as; defaults to
 spamass-milter.
 
+If you want to use an inet socket for spamass-milter (like inet:9999),
+then you'll need to make the following configuration changes in
+/etc/default/spamass-milter:
+
+SOCKET="inet:9999"
+SOCKETMODE=""
+SOCKETOWNER=""
+
 -------------------------------------------------------------
 Debugging spamass-milter
 -------------------------------------------------------------
@@ -118,4 +133,4 @@ q
 
 and send the results along with your bug report using reportbug.
 
- -- Don Armstrong <don@debian.org>, Tue, 20 Jan 2009 19:39:51 -0800
+ -- Don Armstrong <don@debian.org>, Fri, 13 Feb 2009 18:06:39 -0800
index 689e70bf2f67213341d21a7ddcf10e49bae43f32..af904ada46d79c0f28ab664361da976c9a5b51c0 100644 (file)
@@ -1,3 +1,14 @@
+spamass-milter (0.3.1-9) unstable; urgency=low
+
+  * Document that using the -x option requires being in the smmsp group
+    (closes: #515158)
+  * Deal with inet:999 sockets (closes: #514749)
+    - handle them more sanely in the init script
+    - document how to deal with them in README.Debian and
+      /etc/spamass-milter/default
+
+ -- Don Armstrong <don@debian.org>  Fri, 13 Feb 2009 18:13:04 -0800
+
 spamass-milter (0.3.1-8) unstable; urgency=low
 
   * Update the documentation in README.Debian to indicate that a different
index a2c49e07b712db1cffe82bf75c9ee2b74fce8217..afb56f9bfd84c7f5efb1ca4234f7853b39e76da2 100644 (file)
@@ -3,8 +3,12 @@
 # OPTIONS are passed directly to spamass-milter.
 # man spamass-milter for details
 
-# Default, use the nobody user as the default user, ignore messages
-# from localhost
+# Non-standard configuration notes:
+# See README.Debian if you use the -x option with sendmail
+# You should not pass the -d option in OPTIONS; use SOCKET for that.
+
+# Default, use the spamass-milter user as the default user, ignore
+# messages from localhost
 OPTIONS="-u spamass-milter -i 127.0.0.1"
 
 # Reject emails with spamassassin scores > 15.
index f875cd4b89367cbc08287b9769a0b451f4d4213f..907f97fdd9423759b3f82943143f4a5f7730ca6d 100644 (file)
@@ -98,21 +98,28 @@ start() {
            chown "$RUNAS" $(dirname $PIDFILE);
        fi;
     fi;
-    if [ ! -d $(dirname $SOCKET) ]; then
+    # if the dirname is '.', then it's some kind of odd socket, like
+    # an inet socket. Don't create the directory in such a case
+    if [ $(dirname $SOCKET) != "." ] && [ ! -d $(dirname $SOCKET) ]; then
        mkdir -p $(dirname $SOCKET);
        if [ -n "$SOCKETOWNER" ]; then
            chown "$RUNAS" $(dirname $SOCKET);
        fi;
     fi;
-    if [ -n "$RUNAS" ] && [ -d $(dirname $PIDFILE) ] && [ "$(stat -c '%U' $(dirname $PIDFILE))" != "$RUNAS" ]; then
+    if [ -n "$RUNAS" ] && [ -d $(dirname $PIDFILE) ] &&
+       [ "$(stat -c '%U' $(dirname $PIDFILE))" != "$RUNAS" ]; then
        echo "WARNING: $NAME will run as user $RUNAS but $(dirname $PIDFILE) is not owned by $RUNAS";
        echo "Either delete this directory or chown it appropriately. Startup attempts may fail.";
     fi;
-    if [ -n "$RUNAS" ] && [ -d $(dirname $SOCKET) ] && [ "$(stat -c '%U' $(dirname $SOCKET))" != "$RUNAS" ]; then
+    if [ -n "$RUNAS" ] && [ $(dirname $SOCKET) != "." ] &&
+       [ -d $(dirname $SOCKET) ] &&
+       [ "$(stat -c '%U' $(dirname $SOCKET))" != "$RUNAS" ]; then
        echo "WARNING: $NAME will run as user $RUNAS but $(dirname $SOCKET) is not owned by $RUNAS";
        echo "Either delete this directory or chown it appropriately. Startup attempts may fail.";
     fi;
-    /bin/rm -f $SOCKET
+    if [ $(dirname $SOCKET) != "." ]; then 
+       /bin/rm -f $SOCKET
+    fi;
     start-stop-daemon --start -p $PIDFILE $CHUID --exec $DAEMON -- -P $PIDFILE -f -p $SOCKET $OPTIONS
     sleep 1s
     if [ -n "$SOCKETMODE" ]; then