]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
* Sanitize the makefile to not be so repetitive
authordon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Mon, 30 Mar 2009 06:31:30 +0000 (06:31 +0000)
committerdon <don@8f7917da-ec0b-0410-a553-b9b0e350d17e>
Mon, 30 Mar 2009 06:31:30 +0000 (06:31 +0000)
* Add -insane package to include the .95 wordlists
* Include hacker special wordlist in the insane dictionaries
* Add homepage field
* Update standards version

git-svn-id: svn+ssh://svn.donarmstrong.com/sites/don_svn/deb_pkgs/scowl/trunk@412 8f7917da-ec0b-0410-a553-b9b0e350d17e

debian/changelog
debian/control
debian/rules
debian/wamerican-insane.info-wordlist [new file with mode: 0644]
debian/wbritish-insane.info-wordlist [new file with mode: 0644]
debian/wcanadian-insane.info-wordlist [new file with mode: 0644]

index 4c15940c65b37915c1785a7291b8b2aea4d1acb6..a0b515eeec9ee5688f8f529e0e78e41c97e008f9 100644 (file)
@@ -6,8 +6,13 @@ scowl (6-3) UNRELEASED; urgency=low
     #304501).
   * Fix supr{essed,ising} issues in english-words.95, thanks to Jidanni
     (closes: #521229)
+  * Sanitize the makefile to not be so repetitive
+  * Add -insane package to include the .95 wordlists
+  * Include hacker special wordlist in the insane dictionaries
+  * Add homepage field
+  * Update standards version
 
- --
+ -- Don Armstrong <don@debian.org>  Sun, 29 Mar 2009 23:29:01 -0700
 
 scowl (6-2.3) unstable; urgency=low
 
index ad9a8ff35384f57f1bf575ebca4cc774b97b7620..7167ec900a6dba0f6e2d87b69488f4edb414c220 100644 (file)
@@ -2,9 +2,10 @@ Source: scowl
 Maintainer: Don Armstrong <don@debian.org>
 Section: text
 Priority: standard
-Standards-Version: 3.7.3
+Standards-Version: 3.8.1
 Build-Depends: debhelper (>= 5)
 Build-Depends-Indep: dictionaries-common-dev (>=0.20)
+Homepage: http://wordlist.sourceforge.net/
 
 Package: scowl
 Architecture: all
@@ -96,6 +97,27 @@ Description: American English dictionary words for /usr/share/dict
  There are also -small and standard versions of this word list,
  and there are wbritish* and wcanadian* packages as well.
 
+Package: wamerican-insane
+Architecture: all
+Section: text
+Priority: optional
+Depends: dictionaries-common (>=0.20), ${misc:Depends}
+Provides: wordlist
+Description: American English dictionary words for /usr/share/dict
+ This package provides the file /usr/share/dict/american-english-insane
+ containing a list of English words with American spellings.
+ This list can be used by spelling checkers, and by programs such
+ as look(1).
+ .
+ This is an even larger list than the one installed by wamerican-huge,
+ and possibly contains invalid words (as well as words that are very
+ uncommon). Nothing prevents you installing both (and others) at the
+ same time.
+ .
+ There are also -small and standard versions of this word list,
+ and there are wbritish* and wcanadian* packages as well.
+
+
 Package: wbritish
 Architecture: all
 Section: text
@@ -165,6 +187,26 @@ Description: British English dictionary words for /usr/share/dict
  There are also -small and standard versions of this word list,
  and there are wamerican* and wcanadian* packages as well.
 
+Package: wbritish-insane
+Architecture: all
+Section: text
+Priority: optional
+Depends: dictionaries-common (>=0.20), ${misc:Depends}
+Provides: wordlist
+Description: British English dictionary words for /usr/share/dict
+ This package provides the file /usr/share/dict/british-english-insane
+ containing a list of English words with British spellings.
+ This list can be used by spelling checkers, and by programs such
+ as look(1).
+ .
+ This is an even larger list than the one installed by wbritish-huge,
+ and possibly contains invalid words (as well as words that are very
+ uncommon). Nothing prevents you installing both (and others) at the
+ same time.
+ .
+ There are also -small and standard versions of this word list,
+ and there are wamerican* and wcanadian* packages as well.
+
 Package: wcanadian
 Architecture: all
 Section: text
@@ -233,3 +275,24 @@ Description: Canadian English dictionary words for /usr/share/dict
  .
  There are also -small and standard versions of this word list,
  and there are wbritish* and wamerican* packages as well.
+
+Package: wcanadian-insane
+Architecture: all
+Section: text
+Priority: optional
+Depends: dictionaries-common (>=0.20), ${misc:Depends}
+Provides: wordlist
+Description: Canadian English dictionary words for /usr/share/dict
+ This package provides the file /usr/share/dict/canadian-english-insane
+ containing a list of English words with Canadian spellings.
+ This list can be used by spelling checkers, and by programs such
+ as look(1).
+ .
+ This is an even larger list than the one installed by wcanadian-huge,
+ and possibly contains invalid words (as well as words that are very
+ uncommon). Nothing prevents you installing both (and others) at the
+ same time.
+ .
+ There are also -small and standard versions of this word list,
+ and there are wbritish* and wamerican* packages as well.
+
index bb11f97c8f8dbb0d7b32be4ed7b9de6213f5bc55..a66c8e79a9084816f8ec87f2c99b212fd34f13bc 100755 (executable)
@@ -16,15 +16,21 @@ export DH_OPTIONS
 # The medium size packages have no -size part in their names
 # These are the scowl extensions (complexity numbers?) that contribute to each word list (i.e. each size);
 # the -size parts "-small", "", "-large", and "-huge" correspond to the end of the binary package name:
+empty:=
+SIZES=small "" large huge insane
 SIZE_EXTENSIONS_small:=10 20 35
 SIZE_EXTENSIONS:=$(SIZE_EXTENSIONS_small) 40 50
 SIZE_EXTENSIONS_large:=$(SIZE_EXTENSIONS) 55 60 70
-SIZE_EXTENSIONS_huge:=$(SIZE_EXTENSIONS_large) 80 95
+SIZE_EXTENSIONS_huge:=$(SIZE_EXTENSIONS_large) 80
+SIZE_EXTENSIONS_insane:=$(SIZE_EXTENSIONS_huge) 95
 #SIZE_EXTENSIONS-huge:=10 20 35 40 50 55 60 70 80 95
 export SIZE_EXTENSIONS_small
 export SIZE_EXTENSIONS
 export SIZE_EXTENSIONS_large
 export SIZE_EXTENSIONS_huge
+export SIZE_EXTENSIONS_insane
+
+SPELLINGS:= american british canadian
 
 # These are the scowl word list classes we use:
 CLASSES:=words proper-names upper contractions
@@ -35,8 +41,8 @@ build-stamp:
        dh_testdir
 
        set -e;\
-       for SPELLING in american british canadian; do\
-         for SIZE in small "" large huge; do\
+       for SPELLING in $(SPELLINGS); do\
+         for SIZE in $(SIZES); do\
            if [ -n "$$SIZE" ]; then SIZE_NAME="_$$SIZE"; SIZE="-$$SIZE"; else SIZE_NAME=""; SIZE=""; fi; \
            echo "The following SCOWL word lists were concatenated and sorted (with duplicates" > w$$SPELLING$$SIZE.scowl-word-lists-used;\
            echo "removed) to create this word list (see README.Debian for more details):" >> w$$SPELLING$$SIZE.scowl-word-lists-used;\
@@ -55,6 +61,13 @@ build-stamp:
                    echo "  variant_$$VARIANT-$$CLASS.$$EXT" >> w$$SPELLING$$SIZE.scowl-word-lists-used;\
                  fi;\
                done;\
+               if [ "$$SIZE" = "insane" ]; then\
+                 for special in special_hacker.50; do \
+                   echo "cat final/$$special >> $$SPELLING-english$$SIZE.unsorted";\
+                   cat final/final/$$special >> $$SPELLING-english$$SIZE.unsorted;\
+                   echo "  final/$$special" >> w$$SPELLING$$SIZE.scowl-word-lists-used;\
+                 done;\
+               fi;\
                if [ -f final/$$SPELLING-$$CLASS.$$EXT ]; then\
                  echo "cat final/$$SPELLING-$$CLASS.$$EXT >> $$SPELLING-english$$SIZE.unsorted";\
                  cat final/$$SPELLING-$$CLASS.$$EXT >> $$SPELLING-english$$SIZE.unsorted;\
@@ -76,8 +89,9 @@ clean:
        rm -f build-stamp
 
        set -e;\
-       for SIZE in -small "" -large -huge; do\
-         for SPELLING in american british canadian; do\
+       for SIZE in $(SIZES); do\
+         if [ -n "$$SIZE" ]; then SIZE="-$$SIZE"; fi; \
+         for SPELLING in $(SPELLINGS); do\
            rm -f $$SPELLING-english$$SIZE.unsorted $$SPELLING-english$$SIZE $$SPELLING-english$$SIZE.5 w$$SPELLING$$SIZE.scowl-word-lists-used;\
          done;\
        done
@@ -86,16 +100,11 @@ clean:
 
 
 install: DH_OPTIONS=
-install: install-scowl \
- install-wamerican install-wamerican-small install-wamerican-large install-wamerican-huge \
- install-wbritish install-wbritish-small install-wbritish-large install-wbritish-huge \
- install-wcanadian install-wcanadian-small install-wcanadian-large install-wcanadian-huge
+install: install-scowl $(patsubst %-"",%,$(foreach spelling,$(SPELLINGS),$(foreach size,$(SIZES),install-w$(spelling)-$(size))))
        installdeb-wordlist -pwamerican --noscripts
        dh_installdebconf -pwamerican
        installdeb-wordlist --no-package=wamerican --no-package=scowl
 
-
-
 .PHONY: install-scowl
 install-scowl: PKG=scowl
 install-scowl:
@@ -107,72 +116,18 @@ install-scowl:
        dh_installdocs --package=$(PKG) README debian/README.Debian
 
 
-.PHONY: install-wordlist
-install-wordlist:
-#      PKG and WORDLIST must have been set to the binary package name and word list file name, respectively.
+# this is the install-w$(SPELLING)-$(VARIANT) rule
+.PHONY: $(patsubst %-"",%,$(foreach spelling,$(SPELLINGS),$(foreach size,$(SIZES),install-w$(spelling)-$(size))))
+THISPKG=$(patsubst install-%,%,$@)
+WORDLIST=$(shell echo $@|sed -re 's/^install-w([a-z]*)(-*[a-z]*)/\1-english\2/')
+$(patsubst %-"",%,$(foreach spelling,$(SPELLINGS),$(foreach size,$(SIZES),install-w$(spelling)-$(size)))): build-stamp
        dh_testdir
        dh_testroot
-       dh_installdirs --package=$(PKG)
-
-       dh_install --package=$(PKG) $(WORDLIST) usr/share/dict
-
-       dh_installdocs --package=$(PKG) $(PKG).scowl-word-lists-used debian/README.Debian
-
+       dh_installdirs --package=$(THISPKG)
+       dh_install --package=$(THISPKG) $(WORDLIST) usr/share/dict
+       dh_installdocs --package=$(THISPKG) $(THISPKG).scowl-word-lists-used debian/README.Debian
        sed "s/WORDLIST/$(WORDLIST)/g" < debian/wordlist_manpage_template > $(WORDLIST).5
-       dh_installman --package=$(PKG) $(WORDLIST).5
-
-
-.PHONY: install-wamerican
-install-wamerican: build-stamp
-        $(MAKE) -f debian/rules PKG=wamerican WORDLIST=american-english install-wordlist
-
-.PHONY: install-wamerican-small
-install-wamerican-small: build-stamp
-        $(MAKE) -f debian/rules PKG=wamerican-small WORDLIST=american-english-small install-wordlist
-
-.PHONY: install-wamerican-large
-install-wamerican-large: build-stamp
-        $(MAKE) -f debian/rules PKG=wamerican-large WORDLIST=american-english-large install-wordlist
-
-.PHONY: install-wamerican-huge
-install-wamerican-huge: build-stamp
-        $(MAKE) -f debian/rules PKG=wamerican-huge WORDLIST=american-english-huge install-wordlist
-
-
-.PHONY: install-wbritish
-install-wbritish: build-stamp
-        $(MAKE) -f debian/rules PKG=wbritish WORDLIST=british-english install-wordlist
-
-.PHONY: install-wbritish-small
-install-wbritish-small: build-stamp
-        $(MAKE) -f debian/rules PKG=wbritish-small WORDLIST=british-english-small install-wordlist
-
-.PHONY: install-wbritish-large
-install-wbritish-large: build-stamp
-        $(MAKE) -f debian/rules PKG=wbritish-large WORDLIST=british-english-large install-wordlist
-
-.PHONY: install-wbritish-huge
-install-wbritish-huge: build-stamp
-        $(MAKE) -f debian/rules PKG=wbritish-huge WORDLIST=british-english-huge install-wordlist
-
-
-.PHONY: install-wcanadian
-install-wcanadian: build-stamp
-        $(MAKE) -f debian/rules PKG=wcanadian WORDLIST=canadian-english install-wordlist
-
-.PHONY: install-wcanadian-small
-install-wcanadian-small: build-stamp
-        $(MAKE) -f debian/rules PKG=wcanadian-small WORDLIST=canadian-english-small install-wordlist
-
-.PHONY: install-wcanadian-large
-install-wcanadian-large: build-stamp
-        $(MAKE) -f debian/rules PKG=wcanadian-large WORDLIST=canadian-english-large install-wordlist
-
-.PHONY: install-wcanadian-huge
-install-wcanadian-huge: build-stamp
-        $(MAKE) -f debian/rules PKG=wcanadian-huge WORDLIST=canadian-english-huge install-wordlist
-
-
+       dh_installman --package=$(THISPKG) $(WORDLIST).5
 
 # This single target is used to build all the packages, all at once, or
 # one at a time. So keep in mind: any options passed to commands here will
@@ -198,9 +153,5 @@ binary-indep: build install
 # Build architecture dependant packages using the common target.
 binary-arch: build install
 
-# Any other binary targets build just one binary package at a time.
-binary-%: build install
-       make -f debian/rules binary-common DH_OPTIONS=-p$*
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary-common binary install
diff --git a/debian/wamerican-insane.info-wordlist b/debian/wamerican-insane.info-wordlist
new file mode 100644 (file)
index 0000000..3026db5
--- /dev/null
@@ -0,0 +1,2 @@
+Language: american-insane (American English -- insane)
+Hash-Name: american-english-insane
diff --git a/debian/wbritish-insane.info-wordlist b/debian/wbritish-insane.info-wordlist
new file mode 100644 (file)
index 0000000..b970d86
--- /dev/null
@@ -0,0 +1,2 @@
+Language: british-insane (British English -- insane)
+Hash-Name: british-english-insane
diff --git a/debian/wcanadian-insane.info-wordlist b/debian/wcanadian-insane.info-wordlist
new file mode 100644 (file)
index 0000000..2048a76
--- /dev/null
@@ -0,0 +1,2 @@
+Language: canadian-insane (Canadian English -- insane)
+Hash-Name: canadian-english-insane