]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
call install-myspell to register hunspell dictionaries (#696777)
authorDon Armstrong <don@donarmstrong.com>
Tue, 24 Apr 2018 23:54:13 +0000 (16:54 -0700)
committerDon Armstrong <don@donarmstrong.com>
Tue, 24 Apr 2018 23:54:13 +0000 (16:54 -0700)
debian/changelog
debian/hunspell-en-au.info-hunspell [new file with mode: 0644]
debian/hunspell-en-ca.info-hunspell [new file with mode: 0644]
debian/hunspell-en-us.info-hunspell [new file with mode: 0644]
debian/rules

index 2801dbd831244862839dcf83cd28b2c9a0fbd8a8..5e5f4a7661644e0e62e6bbacb9aa246ca23b7f17 100644 (file)
@@ -6,6 +6,8 @@ scowl (2018.04.16-1) unstable; urgency=medium
   * Fix failure to build reproducibly with new debhelper versions due to
     wrong install: and build: targets in Makefile. (Closes: #890618)
     Thanks to Chris Lamb.
   * Fix failure to build reproducibly with new debhelper versions due to
     wrong install: and build: targets in Makefile. (Closes: #890618)
     Thanks to Chris Lamb.
+  * Call install-myspell to register the hunspell dictionaries (Closes:
+    #696777)
 
  -- Don Armstrong <don@debian.org>  Tue, 24 Apr 2018 16:08:24 -0700
 
 
  -- Don Armstrong <don@debian.org>  Tue, 24 Apr 2018 16:08:24 -0700
 
diff --git a/debian/hunspell-en-au.info-hunspell b/debian/hunspell-en-au.info-hunspell
new file mode 100644 (file)
index 0000000..f5243f5
--- /dev/null
@@ -0,0 +1,4 @@
+Language: English (Australian)
+Hash-Name: en_AU
+Emacsen-Name: english_australian
+Coding-System: UTF-8
diff --git a/debian/hunspell-en-ca.info-hunspell b/debian/hunspell-en-ca.info-hunspell
new file mode 100644 (file)
index 0000000..bed3431
--- /dev/null
@@ -0,0 +1,4 @@
+Language: English (Canadian)
+Hash-Name: en_CA
+Emacsen-Name: english_canadian
+Coding-System: UTF-8
diff --git a/debian/hunspell-en-us.info-hunspell b/debian/hunspell-en-us.info-hunspell
new file mode 100644 (file)
index 0000000..96ed446
--- /dev/null
@@ -0,0 +1,4 @@
+Language: English (American)
+Hash-Name: en_US
+Emacsen-Name: english_american
+Coding-System: UTF-8
index 70f1bca08eaa2d2a787d4d728016ad0985e1e89c..3e0aa21e088f0ec2ac6fd7870ec941048aa00544 100755 (executable)
@@ -114,6 +114,7 @@ INSTALL_WORDLISTS=$(patsubst %-"",%,$(foreach spelling,$(SPELLINGS),$(foreach si
 override_dh_auto_install: install-scowl install-hunspell $(INSTALL_WORDLISTS)
        installdeb-wordlist -pwamerican --noscripts
        installdeb-wordlist --no-package=wamerican --no-package=scowl --no-package=hunspell-en-us --no-package=hunspell-en-au --no-package=hunspell-en-ca
 override_dh_auto_install: install-scowl install-hunspell $(INSTALL_WORDLISTS)
        installdeb-wordlist -pwamerican --noscripts
        installdeb-wordlist --no-package=wamerican --no-package=scowl --no-package=hunspell-en-us --no-package=hunspell-en-au --no-package=hunspell-en-ca
+       installdeb-hunspell -phunspell-en-ca -phunspell-en-au -phunspell-en-us
 
 install-scowl:
        dh_installdirs --package=scowl
 
 install-scowl:
        dh_installdirs --package=scowl