]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
remove build/install: targets and replace with override_dh targets
authorDon Armstrong <don@donarmstrong.com>
Tue, 20 Feb 2018 01:34:16 +0000 (17:34 -0800)
committerDon Armstrong <don@donarmstrong.com>
Tue, 24 Apr 2018 23:07:40 +0000 (16:07 -0700)
debian/changelog
debian/rules

index e5295a3fe161e2ffe133b33cfcf85bff1bd336dd..3244f79fdf03a5caa2f7651f29a9e456d1c3c74b 100644 (file)
@@ -2,8 +2,11 @@ scowl (2017.08.24-2) unstable; urgency=medium
 
   * Use $(DEB_VERSION) for hunspel-en-{us,au,ca} insead of
     $(DEB_VERSION_UPSTREAM) (Closes: #884921)
+  * Fix failure to build reproducibly with new debhelper versions due to
+    wrong install: and build: targets in Makefile. (Closes: #890618)
+    Thanks to Chris Lamb.
 
- --
+ -- Don Armstrong <don@debian.org>  Mon, 19 Feb 2018 17:35:59 -0800
 
 scowl (2017.08.24-1) unstable; urgency=medium
 
index 8cad132ca9cdf8901c630c991403cefa7f195518..70f1bca08eaa2d2a787d4d728016ad0985e1e89c 100755 (executable)
@@ -40,7 +40,7 @@ include /usr/share/dpkg/pkg-info.mk
 %:
        dh $@
 
-build:
+override_dh_auto_build:
        set -e;\
        for SPELLING in $(SPELLINGS); do\
          for SIZE in $(SIZES); do\
@@ -111,13 +111,9 @@ override_dh_auto_clean:
 
 INSTALL_WORDLISTS=$(patsubst %-"",%,$(foreach spelling,$(SPELLINGS),$(foreach size,$(SIZES),install-w$(spelling)-$(size))))
 
-override_dh_auto_install: install build
-
-override_dh_auto_build: 
-
-install: build install-scowl $(INSTALL_WORDLISTS)
+override_dh_auto_install: install-scowl install-hunspell $(INSTALL_WORDLISTS)
        installdeb-wordlist -pwamerican --noscripts
-       installdeb-wordlist --no-package=wamerican --no-package=scowl
+       installdeb-wordlist --no-package=wamerican --no-package=scowl --no-package=hunspell-en-us --no-package=hunspell-en-au --no-package=hunspell-en-ca
 
 install-scowl:
        dh_installdirs --package=scowl