]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/blobdiff - debian/rules
New upstream release
[deb_pkgs/libhtml-calendarmonth-perl.git] / debian / rules
index 5b5956a3ba3c55c644ddfdd3dc154b0b85ce138a..2d33f6ac8992b7da84b39a5bca0742c4962d3349 100755 (executable)
@@ -1,66 +1,4 @@
 #!/usr/bin/make -f
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DESTDIR=$(CURDIR)/debian/$(shell dh_listpackages|head -n 1)
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       perl Makefile.PL INSTALLDIRS=vendor
-       $(MAKE)
-
-       touch $@
-
-test: test-stamp
-test-stamp:
-       dh_testdir
-       $(MAKE) test
-       touch $@
-
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp test-stamp
-
-       if [ -e Makefile ]; then $(MAKE) distclean; fi
-
-       dh_clean
-
-install: build test
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install PREFIX=$(DESTDIR)/usr
-       [ ! -d $(DESTDIR)/usr/lib/perl5 ] || \
-               rmdir -p --ignore-fail-on-non-empty$(DESTDIR)/usr/lib/perl5
-
-# Build architecture-independent files here.
-binary-indep: install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@