]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
add initial work on autorandr packaging
authorDon Armstrong <don@donarmstrong.com>
Mon, 30 Oct 2017 21:35:18 +0000 (14:35 -0700)
committerDon Armstrong <don@donarmstrong.com>
Mon, 30 Oct 2017 21:35:18 +0000 (14:35 -0700)
debian/autorandr.1 [new file with mode: 0644]
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/manpages [new file with mode: 0644]
debian/rules [new file with mode: 0755]
debian/source/format [new file with mode: 0644]
debian/source/options [new file with mode: 0644]

diff --git a/debian/autorandr.1 b/debian/autorandr.1
new file mode 100644 (file)
index 0000000..08b1369
--- /dev/null
@@ -0,0 +1,64 @@
+.\" DO NOT MODIFY THIS FILE!  It was generated by help2man 1.47.4.
+.TH AUTORANDR.PY "1" "October 2017" "autorandr.py 1.2" "Automatically change screen layout"
+.SH NAME
+autorandr.py \- autorandr
+.SH SYNOPSIS
+.B autorandr
+[\fI\,options\/\fR]
+.SH DESCRIPTION
+\fB\-h\fR, \fB\-\-help\fR              get this small help
+\fB\-c\fR, \fB\-\-change\fR            reload current setup
+\fB\-s\fR, \fB\-\-save\fR <profile>    save your current setup to profile <profile>
+\fB\-r\fR, \fB\-\-remove\fR <profile>  remove profile <profile>
+\fB\-l\fR, \fB\-\-load\fR <profile>    load profile <profile>
+\fB\-d\fR, \fB\-\-default\fR <profile> make profile <profile> the default profile
+\fB\-\-skip\-options\fR <option> comma separated list of xrandr arguments (e.g. "gamma")
+.IP
+to skip both in detecting changes and applying a profile
+.PP
+\fB\-\-force\fR                 force (re)loading of a profile
+\fB\-\-fingerprint\fR           fingerprint your current hardware setup
+\fB\-\-config\fR                dump your current xrandr setup
+\fB\-\-dry\-run\fR               don't change anything, only print the xrandr commands
+\fB\-\-debug\fR                 enable verbose output
+\fB\-\-batch\fR                 run autorandr for all users with active X11 sessions
+.IP
+To prevent a profile from being loaded, place a script called "block" in its
+directory. The script is evaluated before the screen setup is inspected, and
+in case of it returning a value of 0 the profile is skipped. This can be used
+to query the status of a docking station you are about to leave.
+.IP
+If no suitable profile can be identified, the current configuration is kept.
+To change this behaviour and switch to a fallback configuration, specify
+\fB\-\-default\fR <profile>.
+.IP
+Another script called "postswitch" can be placed in the directory
+~/.config/autorandr (or ~/.autorandr if you have an old installation) as well
+as in any profile directories: The scripts are executed after a mode switch
+has taken place and can notify window managers.
+.IP
+The following virtual configurations are available:
+.TP
+common
+Clone all connected outputs at the largest common resolution
+.TP
+clone\-largest
+Clone all connected outputs with the largest resolution (scaled down if necessary)
+.TP
+horizontal
+Stack all connected outputs horizontally at their largest resolution
+.TP
+vertical
+Stack all connected outputs vertically at their largest resolution
+.SH "SEE ALSO"
+The full documentation for
+.B autorandr.py
+is maintained as a Texinfo manual.  If the
+.B info
+and
+.B autorandr.py
+programs are properly installed at your site, the command
+.IP
+.B info autorandr.py
+.PP
+should give you access to the complete manual.
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..5c318c2
--- /dev/null
@@ -0,0 +1,6 @@
+autorandr (1.2-1) unstable; urgency=medium
+
+  * Initial release (Closes: #nnnn)  <nnnn is the bug number of your ITP>
+  * Initial control description based on upstream packaging
+
+ -- Don Armstrong <don@debian.org>  Mon, 30 Oct 2017 14:07:26 -0700
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..ec63514
--- /dev/null
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..8c564c1
--- /dev/null
@@ -0,0 +1,19 @@
+Source: autorandr
+Section: x11
+Priority: optional
+Maintainer: Don Armstrong <don@debian.org>
+Build-Depends: debhelper (>= 9), dh-python, python-all, python-setuptools
+Standards-Version: 3.9.8
+Homepage: https://github.com/phillipberndt/autorandr
+# X-Python-Version: >= 2.6
+Vcs-Git: https://git.donarmstrong.com/deb_pkgs/autorandr.git
+Vcs-Browser: https://git.donarmstrong.com/deb_pkgs/autorandr.git
+
+Package: autorandr
+Architecture: all
+Depends: x11-xserver-utils, python2
+Description: Automatically select a display configuration for connected devices
+ Autorandr is a script for managing xrandr configurations based on the
+ connected devices. It can be set up to automatically switch to a
+ stored configuration whenever a change in the configuration is
+ detected.
diff --git a/debian/manpages b/debian/manpages
new file mode 100644 (file)
index 0000000..7473890
--- /dev/null
@@ -0,0 +1 @@
+debian/autorandr.1
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..2d33f6a
--- /dev/null
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+       dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644 (file)
index 0000000..163aaf8
--- /dev/null
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644 (file)
index 0000000..cb61fa5
--- /dev/null
@@ -0,0 +1 @@
+extend-diff-ignore = "^[^/]*[.]egg-info/"