]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Only use name of executable in systemd detection (See #38)
authorPhillip Berndt <phillip.berndt@googlemail.com>
Tue, 24 Nov 2015 18:10:24 +0000 (19:10 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Tue, 24 Nov 2015 18:10:24 +0000 (19:10 +0100)
Makefile

index a8ed7931d3d49f2c4d999083c615c14d3983180f..8eb12e6c93fbdb77780d2545abcd584ebb6f54fb 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,7 @@ uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(cat /proc/1/cmdline)) && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(awk '{print $$1}' /proc/1/cmdline)) && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif