]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/commitdiff
Improved systemd detection (See bug #38, thanks to @blueyed)
authorPhillip Berndt <phillip.berndt@googlemail.com>
Tue, 24 Nov 2015 18:05:46 +0000 (19:05 +0100)
committerPhillip Berndt <phillip.berndt@googlemail.com>
Tue, 24 Nov 2015 18:05:46 +0000 (19:05 +0100)
Makefile

index 122c2f79b807591cb6866ca491602a4866acc686..a8ed7931d3d49f2c4d999083c615c14d3983180f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,7 @@ uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/cmdline && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(cat /proc/1/cmdline)) && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif