]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - README.md
New upstream version 1.14
[deb_pkgs/autorandr.git] / README.md
index 9f92164d43108aa2a1ea2f34fbd124745ac9742f..a7e8bfe9a4ff04a64c73f86841752ebba37ee756 100644 (file)
--- a/README.md
+++ b/README.md
@@ -37,6 +37,7 @@ Contributors to this version of autorandr are:
 
 * Adrián López
 * andersonjacob
+* Alexander Lochmann
 * Alexander Wirt
 * Brice Waegeneire
 * Chris Dunder
@@ -49,6 +50,7 @@ Contributors to this version of autorandr are:
 * Nazar Mokrynskyi
 * Phillip Berndt
 * Rasmus Wriedt Larsen
+* Sam Coulter
 * Simon Wydooghe
 * Stefan Tomanek
 * stormc
@@ -58,6 +60,7 @@ Contributors to this version of autorandr are:
 * Tomasz Bogdal
 * Victor Häggqvist
 * Jan-Oliver Kaiser
+* Alexandre Viau
 
 ## Installation/removal
 
@@ -73,10 +76,15 @@ you can
 
 * Use the [official Arch package](https://www.archlinux.org/packages/community/any/autorandr/).
 * Use the [official Debian package](https://packages.debian.org/sid/x11/autorandr) on sid
-* Use the [ebuild from zugaina](https://gpo.zugaina.org/x11-misc/autorandr) on Gentoo.
+* Use the [FreeBSD Ports Collection](https://www.freshports.org/x11/autorandr/) on FreeBSD.
+* Use the [official Gentoo package](https://packages.gentoo.org/packages/x11-misc/autorandr).
 * Use the
   [nix package](https://github.com/NixOS/nixpkgs/blob/master/nixos/modules/services/misc/autorandr.nix)
   on NixOS.
+* Use the
+  [guix package](https://git.savannah.gnu.org/cgit/guix.git/log/gnu/packages/xdisorg.scm?qt=grep&q=autorandr)
+  on Guix.
+* Use the [SlackBuild](https://slackbuilds.org/repository/14.2/desktop/autorandr/) on Slackware.
 * Use the automated nightlies generated by the
   [openSUSE build service](https://build.opensuse.org/package/show/home:phillipberndt/autorandr)
   for various distributions (RPM and DEB based).
@@ -146,9 +154,20 @@ names in your configuration directory to have autorandr use any of them
 as the default configuration without you having to change the system-wide
 configuration.
 
-You can store default values for any option in an INI-file in
-`~/.config/autorandr/settings.ini` in a section `config`. The most useful
-candidate for doing that is `skip-options`, if you need it.
+You can store default values for any option in an INI-file located at
+`~/.config/autorandr/settings.ini`. In a `config` section, you may place any
+default values in the form `option-name=option-argument`.
+
+A common and effective use of this is to specify default `skip-options`, for
+instance skipping the `gamma` setting if using
+[`redshift`](https://github.com/jonls/redshift) as a daemon.  To implement
+the equivalent of `--skip-options gamma`, your `settings.ini` file should look
+like this:
+
+```
+[config]
+skip-options=gamma
+```
 
 ## Advanced usage
 
@@ -171,6 +190,8 @@ where they will only be executed on changes regarding that specific profile.
 
 Instead (or in addition) to these scripts, you can also place as many executable
 files as you like in subdirectories called `script_name.d` (e.g. `postswitch.d`).
+The order of execution of scripts in these directories is by file name, you can
+force a certain ordering by naming them `10-wallpaper`, `20-restart-wm`, etc.
 
 If a script with the same name occurs multiple times, user configuration
 takes precedence over system configuration (as specified by the
@@ -193,17 +214,30 @@ it has a unique name.
 If you switch back from `docked` to `mobile`, `~/.config/autorandr/postswitch`
 is executed instead of the `docked` specific `postswitch`.
 
-In these scripts, some of autorandr's state is exposed as environment variables
+If you experience issues with xrandr being executed too early after connecting
+a new monitor, then you can use a `predetect` script to delay the execution.
+Write e.g. `sleep 1` into that file to make autorandr wait a second before
+running `xrandr`.
+
+#### Variables
+
+Some of autorandr's state is exposed as environment variables
 prefixed with `AUTORANDR_`, such as:
 - `AUTORANDR_CURRENT_PROFILE`
 - `AUTORANDR_CURRENT_PROFILES`
 - `AUTORANDR_PROFILE_FOLDER`
 - `AUTORANDR_MONITORS`
 
-If you experience issues with xrandr being executed too early after connecting
-a new monitor, then you can use a `predetect` script to delay the execution.
-Write e.g. `sleep 1` into that file to make autorandr wait a second before
-running `xrandr`.
+with the intention that they can be used within the hook scripts.
+
+For instance, you might display which profile has just been activated by
+including the following in a `postswitch` script:
+```sh
+notify-send -i display "Display profile" "$AUTORANDR_CURRENT_PROFILE"
+```
+
+The one kink is that during `preswitch`, `AUTORANDR_CURRENT_PROFILE` is
+reporting the *upcoming* profile rather than the *current* one.
 
 ### Wildcard EDID matching
 
@@ -212,9 +246,76 @@ asterisk to enable wildcard matching: Such EDIDs are matched against connected
 monitors using the usual file name globbing rules. This can be used to create
 profiles matching multiple (or any) monitors.
 
+### udev triggers with NVidia cards
+
+In order for `udev` to detect `drm` events from the native NVidia driver, the
+kernel parameter `nvidia-drm.modeset` must be set to 1. For example, add a file
+`/etc/modprobe.d/nvidia-drm-modeset.conf`:
+
+```
+options nvidia_drm modeset=1
+```
+
+### Wayland
+
+Before running autorandr will check the environment for the `WAYLAND_DISPLAY`
+variable to check if the program is running in a Wayland session. This is to
+avoid issues between usage of xrandr in Wayland environments.
+
+If you need to run autorandr in a Wayland environment, one workaround is to
+unset the `WAYLAND_DISPLAY` variable before running the program, such as:
+
+```
+WAYLAND_DISPLAY= autorandr
+```
+
 ## Changelog
 
-**autorandr 1.10 (dev)**
+**autorandr 1.14**
+* *2023-06-22* Direct --match-edid renaming of output messages to stderr
+* *2023-06-22* Add Wayland awareness
+* *2023-06-22* Various minor auxiliary tooling bug fixes, see git-log
+
+**autorandr 1.13.3**
+* *2023-01-24* Revert udev rule to rely on "change" event (see #324)
+
+**autorandr 1.13.2**
+* *2023-01-23* Fix autostart in KDE (see #320)
+* *2023-01-23* Match add/remove rather than change in udev rule (see #321)
+* *2023-01-23* Fix wildcard use in EDIDs (see #322)
+* *2023-01-23* Do a final xrandr call to set the frame buffer size (see #319)
+
+**autorandr 1.13.1**
+* *2023-01-16* Fix bug with Version comparison
+
+**autorandr 1.13**
+* *2023-01-15* Add reversed horizontal/vertical profiles
+* *2023-01-15* Fix distutils deprecation warning
+* *2023-01-15* Print error when user script fails
+* *2022-12-01* Support `--skip-options set` to skip setting properties
+
+**autorandr 1.12.1**
+* *2021-12-22* Fix `--match-edid` (see #273)
+
+**autorandr 1.12**
+* *2021-12-16* Switch default interpreter to Python 3
+* *2021-12-16* Add `--list` to list all profiles
+* *2021-12-16* Add `--cycle` to cycle all detected profiles
+* *2021-12-16* Store display properties (see #204)
+
+**autorandr 1.11**
+* *2020-05-23* Handle empty sys.executable
+* *2020-06-08* Fix Python 2 compatibility
+* *2020-10-06* Set group membership of users in batch mode
+
+**autorandr 1.10.1**
+* *2020-05-04* Revert making the launcher the default (fixes #195)
+
+**autorandr 1.10**
+* *2020-04-23* Fix hook script execution order to match description from readme
+* *2020-04-11* Handle negative gamma values (fixes #188)
+* *2020-04-11* Sort approximate matches in detected profiles by quality of match
+* *2020-01-31* Handle non-ASCII environment variables (fixes #180)
 * *2019-12-31* Fix output positioning if the top-left output is not the first
 * *2019-12-31* Accept negative gamma values (and interpret them as 0)
 * *2019-12-31* Prefer the X11 launcher over systemd/udev configuration