]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - README.md
Version bump: autorandr 1.5
[deb_pkgs/autorandr.git] / README.md
index 40588558316f32aad26699d2be99d70466254d2d..999f353ceca200629b7ce82493925abba53bf65a 100644 (file)
--- a/README.md
+++ b/README.md
@@ -39,6 +39,7 @@ Contributors to this version of autorandr are:
 * andersonjacob
 * Alexander Wirt
 * Chris Dunder
+* Christoph Gysin
 * Daniel Hahler
 * Maciej Sitarz
 * Mathias Svensson
@@ -61,20 +62,22 @@ You can use the `autorandr.py` script as a stand-alone binary. If you'd like to
 install it as a system-wide application, there is a Makefile included that also
 places some configuration files in appropriate directories such that autorandr
 is invoked automatically when a monitor is connected or removed, the system
-wakes up from suspend, or a user logs into an X11 session.
-
-For Debian-based distributions (including Ubuntu) it is recommended to call
-`make deb` to obtain a package that can be installed and removed with `dpkg`.
-
-On Arch Linux, there is [an aur package
-available](https://aur.archlinux.org/packages/autorandr-git/).
-
-autorandr is also packaged in the [nix package manager](https://nixos.org/nix/)
-repositories.
-
-On other distributions you can install autorandr by calling `make install` and
-remove it by calling `make uninstall`. Run `make` without arguments to obtain a
-list of what exactly will be installed.
+wakes up from suspend, or a user logs into an X11 session. Run `make install`
+as root to install it.
+
+If you prefer to have a system wide install managed by your package manager,
+you can
+
+* Use the [aur package](https://aur.archlinux.org/packages/autorandr-git/) on Arch
+* Use the [official Debian package](https://packages.debian.org/sid/x11/autorandr) on sid
+* Use the [ebuild from zugaina](https://gpo.zugaina.org/x11-misc/autorandr) on Gentoo.
+* Use the
+  [nix package](https://github.com/NixOS/nixpkgs/blob/master/nixos/modules/services/misc/autorandr.nix)
+  on NixOS.
+* Use the automated nightlies generated by the
+  [openSUSE build service](https://build.opensuse.org/package/show/home:phillipberndt/autorandr)
+  for various distributions (RPM and DEB based).
+* Build a .deb-file from the source tree using `make deb`.
 
 We appreciate packaging scripts for other distributions, please file a pull
 request if you write one.
@@ -89,9 +92,6 @@ or simply
 
 if you prefer to use a stable version.
 
-Automatically generated packages versions are available from the
-[openSUSE build service](https://build.opensuse.org/package/show/home:phillipberndt/autorandr).
-
 ## How to use
 
 Save your current display configuration and setup with:
@@ -108,12 +108,22 @@ Now autorandr can detect which hardware setup is active:
       mobile
       docked (detected)
 
-To automatically reload your setup, just append `--change` to the command line
+To automatically reload your setup:
 
-To manually load a profile, you can use the `--load <profile>` option.
+    $ autorandr --change
+
+To manually load a profile:
+
+    $ autorandr --load <profile>
+
+or simply:
+
+    $ autorandr <profile>
 
 autorandr tries to avoid reloading an identical configuration. To force the
-(re)configuration, apply `--force`.
+(re)configuration:
+
+    $ autorandr --load <profile> --force
 
 To prevent a profile from being loaded, place a script call _block_ in its
 directory. The script is evaluated before the screen setup is inspected, and
@@ -131,7 +141,13 @@ names in your configuration directory to have autorandr use any of them
 as the default configuration without you having to change the system-wide
 configuration.
 
-## Hook scripts
+You can store default values for any option in an INI-file in
+`~/.config/autorandr/settings.ini` in a section `config`. The most useful
+candidate for doing that is `skip-options`, if you need it.
+
+## Advanced usage
+
+### Hook scripts
 
 Three more scripts can be placed in the configuration directory (as 
 (as defined by the [XDG spec](https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html),
@@ -180,8 +196,34 @@ a new monitor, then you can use a `predetect` script to delay the execution.
 Write e.g. `sleep 1` into that file to make autorandr wait a second before
 running `xrandr`.
 
+### Wildcard EDID matching
+
+The EDID strings in the `~/.config/autorandr/*/setup` files may contain an
+asterisk to enable wildcard matching: Such EDIDs are matched against connected
+monitors using the usual file name globbing rules. This can be used to create
+profiles matching multiple (or any) monitors.
+
 ## Changelog
 
+**autorandr 1.5**
+
+* *2018-01-03* Add --version
+* *2018-01-04* Fixed vertical/horizontal/clone-largest virtual profiles
+* *2018-03-07* Output all non-error messages to stdout instead of stderr
+* *2018-03-25* Add --detected and --current to filter the profile list output
+* *2018-03-25* Allow wildcard matching in EDIDs
+
+**autorandr 1.4**
+
+* *2017-12-22* Fixed broken virtual profile support
+* *2017-12-14* Added support for a settings file
+* *2017-12-14* Added a virtual profile `off`, which disables all screens
+
+**autorandr 1.3**
+
+* *2017-11-13* Add a short form for `--load`
+* *2017-11-21* Fix environment stealing in `--batch` mode (See #87)
+
 **autorandr 1.2**
 
 * *2017-07-16* Skip `--panning` unless it is required (See #72)