]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
fix infinite loop in debug_regexp
[deb_pkgs/autorandr.git] / Makefile
index a8ee74ae0f8e12cd70506726525f847a45500d1b..f1d27253cad3700472dd6121a8ec197a3470cd39 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,19 @@
+all:
+       @echo "Call \"make install\" to install this program."
+       @echo "Call \"make hotplug\" to install matching hotplug events."
 
+INSTALL_PATH=/usr/local/bin
 install:
-       install -m 774 autorandr          /usr/bin/
-       install -m 774 autorandr_monitor  /usr/bin/
-       install -m 644 bash_completion/autorandr /etc/bash_completion.d/
-       ln -sf /usr/bin/autorandr /usr/bin/auto-disper
-       #install -m 644 /etc/X11/Xsession.d/
-       #install -m 644 pm-utils/40autorandr /etc/pm/power.d/
+       install -D auto-disper ${DESTDIR}${INSTALL_PATH}/auto-disper
+       install -D -m 755 autorandr ${DESTDIR}${INSTALL_PATH}/autorandr
+       install -D -m 644 bash_completion/autorandr ${DESTDIR}/etc/bash_completion.d/autorandr
+
+hotplug:
+       install -D -m 755 pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       install -D -m 644 udev/40-monitor-hotplug.rules ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules
+ifeq (${USER},root)
+       udevadm control --reload-rules
+else
+       @echo "Please run this command as root:"
+       @echo "    udevadm control --reload-rules"
+endif