]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Improved .spec file for RPM builds
[deb_pkgs/autorandr.git] / Makefile
index fd35f6a4ff702e3c592fc4c23037f32e678ea999..d8b27c6e5eac1ce9627e2cb224c3c2aa6473180e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
 DESTDIR=/
 PREFIX=/usr/
+RPM_SPEC=contrib/packaging/rpm/autorandr.spec
 
 .PHONY: all install uninstall autorandr bash_completion autostart_config pmutils systemd udev
 
@@ -151,3 +152,7 @@ uninstall: $(patsubst %,uninstall_%,$(TARGETS))
 
 deb:
        ./contrib/packaging/debian/make_deb.sh
+
+rpm:
+       spectool -g -R $(RPM_SPEC)
+       rpmbuild -ba $(RPM_SPEC)