]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Don't fail hard in get_fb_dimensions if a mode isn't WWWxHHH
[deb_pkgs/autorandr.git] / Makefile
index a36d2e0311855c5fd0effbfac0195c31fc79096f..d8b27c6e5eac1ce9627e2cb224c3c2aa6473180e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
 DESTDIR=/
 PREFIX=/usr/
+RPM_SPEC=contrib/packaging/rpm/autorandr.spec
 
 .PHONY: all install uninstall autorandr bash_completion autostart_config pmutils systemd udev
 
@@ -133,11 +134,9 @@ DEFAULT_TARGETS+=manpage
 install_manpage:
        mkdir -p ${DESTDIR}/${MANDIR}
        cp autorandr.1 ${DESTDIR}/${MANDIR}
-       mandb -qp
 
 uninstall_manpage:
        rm -f ${DESTDIR}/${MANDIR}/autorandr.1
-       mandb -q
 
 # Rules for launcher
 install_launcher:
@@ -153,3 +152,7 @@ uninstall: $(patsubst %,uninstall_%,$(TARGETS))
 
 deb:
        ./contrib/packaging/debian/make_deb.sh
+
+rpm:
+       spectool -g -R $(RPM_SPEC)
+       rpmbuild -ba $(RPM_SPEC)