]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Makefile: use pkg-config
[deb_pkgs/autorandr.git] / Makefile
index 42ee710fcd5c04f0b4fa57dc98df0abf14a5eb25..a7c4f98bd9363ee401dbe89ec377bd3209990365 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
 DESTDIR=/
 PREFIX=/usr/
 
-.PHONY: all install uninstall autorandr bash_completion pmutils systemd udev
+.PHONY: all install uninstall autorandr bash_completion autostart_config pmutils systemd udev
 
 all:
        @echo "Call \"make install\" to install this program."
@@ -9,7 +9,21 @@ all:
        @echo
        @echo "The following components were autodetected and will be installed:"
        @echo " "$(DEFAULT_TARGETS)
-       @echo "You can use the TARGETS variable to override, e.g. \"make install TAGETS='autorandr pmutils'\"."
+       @echo
+       @echo "The following locations have been detected (from pkg-config):"
+       @echo " - SYSTEMD_UNIT_DIR: $(SYSTEMD_UNIT_DIR)"
+       @echo " - UDEV_RULES_DIR: $(UDEV_RULES_DIR)"
+       @echo " - PM_SLEEPHOOKS_DIR: $(PM_SLEEPHOOKS_DIR)"
+       @echo
+       @echo "You can use the TARGETS variable to override this, but need to set"
+       @echo "the SYSTEMD_UNIT_DIR, PM_SLEEPHOOKS_DIR and UDEV_RULES_DIR variables"
+       @echo "in case they were not detected correctly."
+       @echo
+       @echo 'E.g. "make install TARGETS='autorandr pmutils' PM_UTILS_DIR=/etc/pm/sleep.d".'
+       @echo
+       @echo "The following additional targets are available:"
+       @echo
+       @echo "    make deb        creates a Debian package"
 
 # Rules for autorandr itself
 DEFAULT_TARGETS=autorandr
@@ -21,49 +35,65 @@ uninstall_autorandr:
        rm -f ${DESTDIR}${PREFIX}/bin/autorandr
 
 # Rules for bash_completion
+BASH_COMPLETION_DIR=/etc/bash_completion.d
 HAVE_BASH_COMPLETION=$(shell [ -d /etc/bash_completion.d/ ] && echo "y")
 ifeq ($(HAVE_BASH_COMPLETION),y)
 DEFAULT_TARGETS+=bash_completion
 endif
 
 install_bash_completion:
-       install -D -m 644 contrib/bash_completion/autorandr ${DESTDIR}/etc/bash_completion.d/autorandr
+       install -D -m 644 contrib/bash_completion/autorandr ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
 
 uninstall_bash_completion:
-       rm -f ${DESTDIR}/etc/bash_completion.d/autorandr
+       rm -f ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
+
+# Rules for autostart config
+XDG_AUTOSTART_DIR=/etc/xdg/autostart
+DEFAULT_TARGETS+=autostart_config
+
+install_autostart_config:
+       install -D -m 644 contrib/etc/xdg/autostart/autorandr.desktop ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
+
+uninstall_autostart_config:
+       rm -f ${DESTDIR}/${XDG_AUTOSTART_DIR}/autorandr.desktop
 
 # Rules for pmutils
-HAVE_PMUTILS=$(shell [ -x /usr/sbin/pm-suspend ] && echo "y")
-ifeq ($(HAVE_PMUTILS),y)
+PM_SLEEPHOOKS_DIR:=$(shell pkg-config --variable=pm_sleephooks pm-utils 2>/dev/null)
+ifneq (,$(PM_SLEEPHOOKS_DIR))
 DEFAULT_TARGETS+=pmutils
 endif
 
 install_pmutils:
-       install -D -m 755 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       $(if $(PM_SLEEPHOOKS_DIR),,$(error PM_SLEEPHOOKS_DIR is not defined))
+       install -D -m 755 contrib/pm-utils/40autorandr ${DESTDIR}/${PM_SLEEPHOOKS_DIR}/40autorandr
 
 uninstall_pmutils:
-       rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       $(if $(PM_SLEEPHOOKS_DIR),,$(error PM_SLEEPHOOKS_DIR is not defined))
+       rm -f ${DESTDIR}/${PM_SLEEPHOOKS_DIR}/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(awk '{print $$1}' /proc/1/cmdline)) && echo "y")
-ifeq ($(HAVE_SYSTEMD),y)
+SYSTEMD_UNIT_DIR:=$(shell pkg-config --variable=systemdsystemunitdir systemd 2>/dev/null)
+ifneq (,$(SYSTEMD_UNIT_DIR))
 DEFAULT_TARGETS+=systemd
 endif
 
-install_systemd: install_pmutils
-       install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}/etc/systemd/system/autorandr-resume.service
+install_systemd:
+       $(if $(SYSTEMD_UNIT_DIR),,$(error SYSTEMD_UNIT_DIR is not defined))
+       install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}/${SYSTEMD_UNIT_DIR}/autorandr-resume.service
 
-uninstall_systemd: uninstall_pmutils
-       rm -f ${DESTDIR}/etc/systemd/system/autorandr-resume.service
+uninstall_systemd:
+       $(if $(SYSTEMD_UNIT_DIR),,$(error SYSTEMD_UNIT_DIR is not defined))
+       rm -f ${DESTDIR}/${SYSTEMD_UNIT_DIR}/autorandr-resume.service
 
 # Rules for udev
-HAVE_UDEV=$(shell [ -d /etc/udev/rules.d/ ] && echo "y")
-ifeq ($(HAVE_UDEV),y)
+UDEV_RULES_DIR:=$(shell pkg-config --variable=udevdir udev 2>/dev/null)
+ifneq (,$(UDEV_RULES_DIR),y)
 DEFAULT_TARGETS+=udev
 endif
 
 install_udev:
-       install -D -m 644 contrib/udev/40-monitor-hotplug.rules ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules
+       $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))
+       install -D -m 644 contrib/udev/40-monitor-hotplug.rules ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
 ifeq (${USER},root)
        udevadm control --reload-rules
 else
@@ -72,9 +102,13 @@ else
 endif
 
 uninstall_udev:
-       rm -f ${DESTDIR}/etc/udev/rules.d/40-monitor-hotplug.rules
+       $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))
+       rm -f ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
 
 
 TARGETS=$(DEFAULT_TARGETS)
 install: $(patsubst %,install_%,$(TARGETS))
 uninstall: $(patsubst %,uninstall_%,$(TARGETS))
+
+deb:
+       ./contrib/packaging/debian/make_deb.sh