]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Merge branch 'master' into manpage
[deb_pkgs/autorandr.git] / Makefile
index 989c250fb9860427b2e34c7601a08d4086250b0d..a36d2e0311855c5fd0effbfac0195c31fc79096f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,11 @@ all:
        @echo
        @echo 'E.g. "make install TARGETS='autorandr pmutils' PM_UTILS_DIR=/etc/pm/sleep.d".'
        @echo
+       @echo "An additional TARGETS variable \"launcher\" is available. This"
+       @echo "installs a launcher called \"autorandr_launcher\". The launcher"
+       @echo "is able to be run by the user and calls autorandr automatically"
+       @echo "without using udev rules."
+       @echo
        @echo "The following additional targets are available:"
        @echo
        @echo "    make deb        creates a Debian package"
@@ -134,6 +139,14 @@ uninstall_manpage:
        rm -f ${DESTDIR}/${MANDIR}/autorandr.1
        mandb -q
 
+# Rules for launcher
+install_launcher:
+       gcc -Wall contrib/autorandr_launcher/autorandr_launcher.c -o contrib/autorandr_launcher/autorandr_launcher -lxcb -lxcb-randr
+       install -D -m 755 contrib/autorandr_launcher/autorandr_launcher ${DESTDIR}${PREFIX}/bin/autorandr_launcher
+
+uninstall_launcher:
+       rm -f ${DESTDIR}${PREFIX}/bin/autorandr_launcher
+
 TARGETS=$(DEFAULT_TARGETS)
 install: $(patsubst %,install_%,$(TARGETS))
 uninstall: $(patsubst %,uninstall_%,$(TARGETS))