]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Merge remote-tracking branch 'queezythegreat/master'
[deb_pkgs/autorandr.git] / Makefile
index 49d598e8f70654b2e18f2d497bab08ce92866d9d..a22a058c0d1e80e09fdc24ee129e534914b48413 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,14 @@
+all:
+       @echo "Call \"make install\" to install this program."
+       @echo "Call \"make hotplug\" to install matching hotplug events."
 
+INSTALL_PATH=/usr/local/bin
 install:
-       install -m 775 autorandr          /usr/bin/
-       install -m 775 autorandr_monitor  /usr/bin/
+       install auto-disper ${INSTALL_PATH}
+       install -m 755 autorandr ${INSTALL_PATH}
        install -m 644 bash_completion/autorandr /etc/bash_completion.d/
-       ln -sf /usr/bin/autorandr /usr/bin/auto-disper
-       install -m 644 Xsession.d/autorandr /etc/X11/Xsession.d/99zautorandr
-       #install -m 644 pm-utils/40autorandr /etc/pm/power.d/
+
+hotplug:
+       install -m 755 pm-utils/40autorandr /etc/pm/sleep.d/
+       install -m 644 udev/40-monitor-hotplug.rules /etc/udev/rules.d/
+       udevadm control --reload-rules