]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Add a configuration file for default option values
[deb_pkgs/autorandr.git] / Makefile
index 6c3513c698ee746be2afd335da9255fb6ac22084..87b1b4dd0a9ac434d39e496bea4b826bc7a2205f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,7 @@ all:
        @echo " "$(DEFAULT_TARGETS)
        @echo
        @echo "The following locations have been detected (from pkg-config):"
+       @echo " - BASH_COMPLETIONS_DIR: $(BASH_COMPLETIONS_DIR)"
        @echo " - SYSTEMD_UNIT_DIR: $(SYSTEMD_UNIT_DIR)"
        @echo " - UDEV_RULES_DIR: $(UDEV_RULES_DIR)"
        @echo " - PM_SLEEPHOOKS_DIR: $(PM_SLEEPHOOKS_DIR)"
@@ -34,18 +35,17 @@ install_autorandr:
 uninstall_autorandr:
        rm -f ${DESTDIR}${PREFIX}/bin/autorandr
 
-# Rules for bash_completion
-BASH_COMPLETION_DIR=/etc/bash_completion.d
-HAVE_BASH_COMPLETION=$(shell [ -d /etc/bash_completion.d/ ] && echo "y")
-ifeq ($(HAVE_BASH_COMPLETION),y)
+# Rules for bash-completion
+BASH_COMPLETIONS_DIR:=$(shell pkg-config --variable=completionsdir bash-completion 2>/dev/null)
+ifneq (,$(BASH_COMPLETIONS_DIR))
 DEFAULT_TARGETS+=bash_completion
 endif
 
 install_bash_completion:
-       install -D -m 644 contrib/bash_completion/autorandr ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
+       install -D -m 644 contrib/bash_completion/autorandr ${DESTDIR}/${BASH_COMPLETIONS_DIR}/autorandr
 
 uninstall_bash_completion:
-       rm -f ${DESTDIR}/${BASH_COMPLETION_DIR}/autorandr
+       rm -f ${DESTDIR}/${BASH_COMPLETIONS_DIR}/autorandr
 
 # Rules for autostart config
 XDG_AUTOSTART_DIR=/etc/xdg/autostart
@@ -72,6 +72,11 @@ install_systemd:
 ifneq ($(PREFIX),/usr/)
        sed -i -re 's#/usr/bin/autorandr#$(subst #,\#,${PREFIX})/bin/autorandr#g' ${DESTDIR}/${SYSTEMD_UNIT_DIR}/autorandr.service
 endif
+       @echo
+       @echo "To activate the systemd unit, run this command as root:"
+       @echo "    systemctl daemon-reload"
+       @echo "    systemctl enable autorandr.service"
+       @echo
 
 uninstall_systemd:
        $(if $(SYSTEMD_UNIT_DIR),,$(error SYSTEMD_UNIT_DIR is not defined))
@@ -105,13 +110,12 @@ endif
 
 install_udev:
        $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))
-       install -D -m 644 contrib/udev/40-monitor-hotplug.rules ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
-ifeq (${USER},root)
-       udevadm control --reload-rules
-else
-       @echo "Please run this command as root:"
+       mkdir -p ${DESTDIR}/${UDEV_RULES_DIR}/
+       echo 'ACTION=="change", SUBSYSTEM=="drm", RUN+="$(if $(findstring systemd, $(TARGETS)),/bin/systemctl start --no-block autorandr.service,${PREFIX}/bin/autorandr --batch --change --default default)"' > ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
+       @echo
+       @echo "To activate the udev rules, run this command as root:"
        @echo "    udevadm control --reload-rules"
-endif
+       @echo
 
 uninstall_udev:
        $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))