]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Retry failed xrandr calls after waiting for one second to mitigate #47
[deb_pkgs/autorandr.git] / Makefile
index 122c2f79b807591cb6866ca491602a4866acc686..42ee710fcd5c04f0b4fa57dc98df0abf14a5eb25 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,13 +39,13 @@ DEFAULT_TARGETS+=pmutils
 endif
 
 install_pmutils:
-       install -D -m 644 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       install -D -m 755 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/cmdline && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(awk '{print $$1}' /proc/1/cmdline)) && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif