]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Fix systemd detection, closes #48
[deb_pkgs/autorandr.git] / Makefile
index 42ee710fcd5c04f0b4fa57dc98df0abf14a5eb25..30419ac3d7a2c763f5302ba468dc65919f24a2a9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,7 @@ uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd $$(readlink -f $$(awk '{print $$1}' /proc/1/cmdline)) && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/comm && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif