]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - Makefile
Introduce --batch option to autorandr: Run autorandr for each user with an X11 session
[deb_pkgs/autorandr.git] / Makefile
index 122c2f79b807591cb6866ca491602a4866acc686..10570e48618fdd98b8166c5ffc329751c72446a1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,21 +39,21 @@ DEFAULT_TARGETS+=pmutils
 endif
 
 install_pmutils:
-       install -D -m 644 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
+       install -D -m 755 contrib/pm-utils/40autorandr ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 uninstall_pmutils:
        rm -f ${DESTDIR}/etc/pm/sleep.d/40autorandr
 
 # Rules for systemd
-HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/cmdline && echo "y")
+HAVE_SYSTEMD=$(shell grep -q systemd /proc/1/comm && echo "y")
 ifeq ($(HAVE_SYSTEMD),y)
 DEFAULT_TARGETS+=systemd
 endif
 
-install_systemd: install_pmutils
+install_systemd:
        install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}/etc/systemd/system/autorandr-resume.service
 
-uninstall_systemd: uninstall_pmutils
+uninstall_systemd:
        rm -f ${DESTDIR}/etc/systemd/system/autorandr-resume.service
 
 # Rules for udev