]> git.donarmstrong.com Git - cran2deb.git/blobdiff - trunk/R/debianpkg.R
the Rmpi and npRmpi packages fail at the end of R CMD INSTALL because the test load...
[cran2deb.git] / trunk / R / debianpkg.R
index e3656d31e8ae284133600aef506fe2db0a9ac618..8e3f8d8279839a7c463ee19a42d7341b30ce3ac1 100644 (file)
@@ -37,6 +37,9 @@ generate_rules <- function(pkg) {
              ,'include /usr/share/R/debian/r-cran.mk'
              ,'',sep='\n')
        ,file=pkg$debfile('rules'))
+    if (pkg$name %in% c("Rmpi", "npRmpi")) {
+        cat("extraInstallFlags=\"--no-test-load\"\n", file=pkg$debfile('rules'), append=TRUE)
+    }      
     Sys.chmod(pkg$debfile('rules'),'0700')
 }