]> git.donarmstrong.com Git - bamtools.git/blobdiff - src/utils/CMakeLists.txt
Cleaned up intra-API includes & moved version numbers to 2.0.0
[bamtools.git] / src / utils / CMakeLists.txt
index f93835bb97ead4fb1531ed3facef6cf4c3819097..46e72352ef1005f4c8b2a3f4a2bb00442e2d2f13 100644 (file)
@@ -9,7 +9,8 @@
 include_directories (${BamTools_SOURCE_DIR}/src/api) 
 
 # add compiler definitions 
-#add_definitions(-DBAMTOOLS_UTILS_LIBRARY) # (for proper exporting of library symbols)
+add_definitions(-DBAMTOOLS_UTILS_LIBRARY) # (for proper exporting of library symbols)
+add_definitions( -fPIC ) # (attempt to force PIC compiling on CentOS, not being set on shared libs by CMake)
 
 # create BamTools utils library
 add_library ( BamTools-utils SHARED 
@@ -24,6 +25,6 @@ target_link_libraries ( BamTools-utils BamTools )
 
 # set BamTools library properties
 set_target_properties( BamTools-utils PROPERTIES
-                       SOVERSION   0.9.0
+                       SOVERSION   2.0.0
                        OUTPUT_NAME bamtools-utils
                      )