]> git.donarmstrong.com Git - bamtools.git/blobdiff - src/third_party/jsoncpp/CMakeLists.txt
Minor version bump - 2.3.0
[bamtools.git] / src / third_party / jsoncpp / CMakeLists.txt
index 3fc9ec47bd1786c58d98c52995ba0ff6c5eb6aea..8dc64e43c8cf6aef092b750af337d91ade2dd104 100644 (file)
@@ -6,17 +6,18 @@
 # ==========================
 
 # add compiler definitions 
-add_definitions(-DBAMTOOLS_JSONCPP_LIBRARY) # (for proper exporting of library symbols)
+add_definitions( -DBAMTOOLS_JSONCPP_LIBRARY ) # (for proper exporting of library symbols)
+add_definitions( -fPIC ) # (attempt to force PIC compiling on CentOS, not being set on shared libs by CMake)
 
 # create jsoncpp library
-add_library ( jsoncpp SHARED 
-              json_reader.cpp
-              json_value.cpp
-              json_writer.cpp
-            )
+add_library( jsoncpp STATIC
+             json_reader.cpp
+             json_value.cpp
+             json_writer.cpp
+           )
 
 # set jsoncpp library properties
 set_target_properties( jsoncpp PROPERTIES
-                       SOVERSION   1.0.0
                        OUTPUT_NAME jsoncpp
+                       PREFIX "lib"
                      )