]> git.donarmstrong.com Git - bamtools.git/blobdiff - src/api/CMakeLists.txt
Related to last commit - fixed another instance of '_WIN32'
[bamtools.git] / src / api / CMakeLists.txt
index 66eb35f9f301478976acb9e24f02318a97fe07c6..a9dd0924a2925e7c661f71e6267b02489961b943 100644 (file)
@@ -13,7 +13,7 @@ add_definitions( -DBAMTOOLS_API_LIBRARY ) # (for proper exporting of library sym
 add_definitions( -fPIC ) # (attempt to force PIC compiling on CentOS, not being set on shared libs by CMake)
 
 # fetch all internal source files
-add_subdirectory ( internal )
+add_subdirectory( internal )
 
 # make list of all API source files
 set( BamToolsAPISources
@@ -44,11 +44,11 @@ set_target_properties( BamTools-static PROPERTIES
                        PREFIX "lib" )
 
 # link libraries automatically with zlib (and Winsock2, if applicable)
-if( _WIN32 )
+if( WIN32 )
     set( APILibs z ws2_32 )
-else( _WIN32 )
+else()
     set( APILibs z )
-endif( _WIN32 )
+endif()
 
 target_link_libraries( BamTools ${APILibs} )
 target_link_libraries( BamTools-static ${APILibs} )