]> git.donarmstrong.com Git - bamtools.git/blobdiff - src/api/CMakeLists.txt
Related to last commit - fixed another instance of '_WIN32'
[bamtools.git] / src / api / CMakeLists.txt
index 539feca0317a4e801ce14fa34626c0a98849e654..a9dd0924a2925e7c661f71e6267b02489961b943 100644 (file)
@@ -13,7 +13,7 @@ add_definitions( -DBAMTOOLS_API_LIBRARY ) # (for proper exporting of library sym
 add_definitions( -fPIC ) # (attempt to force PIC compiling on CentOS, not being set on shared libs by CMake)
 
 # fetch all internal source files
-add_subdirectory ( internal )
+add_subdirectory( internal )
 
 # make list of all API source files
 set( BamToolsAPISources
@@ -34,7 +34,7 @@ set( BamToolsAPISources
 # create main BamTools API shared library
 add_library( BamTools SHARED ${BamToolsAPISources} )
 set_target_properties( BamTools PROPERTIES
-                       SOVERSION "2.0.5"
+                       SOVERSION "2.2.3"
                        OUTPUT_NAME "bamtools" )
 
 # create main BamTools API static library
@@ -43,12 +43,12 @@ set_target_properties( BamTools-static PROPERTIES
                        OUTPUT_NAME "bamtools" 
                        PREFIX "lib" )
 
-# link libraries with zlib automatically
-if ( _WIN32 )
+# link libraries automatically with zlib (and Winsock2, if applicable)
+ifWIN32 )
     set( APILibs z ws2_32 )
-else ( _WIN32 )
+else()
     set( APILibs z )
-endif ( _WIN32 )
+endif()
 
 target_link_libraries( BamTools ${APILibs} )
 target_link_libraries( BamTools-static ${APILibs} )