]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Install custom synaptics filter for NeuroDebian.
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:36:06 +0000 (16:36 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:36:40 +0000 (16:36 -0400)
debian/changelog
tools/nd-vmsetupwizard

index 80746411b8abb7ef9795604f281778371c73b369..4fc8522a635ecfaa7aa854ac381b0e0d41eac27e 100644 (file)
@@ -1,5 +1,5 @@
-neurodebian (0.8) squeeze; urgency=low
+neurodebian (0.9) squeeze; urgency=low
 
   * Initial release.
 
- -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 16:11:48 -0400
+ -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 16:36:24 -0400
index 1927bd304395822d4ee9f4e698bedfb0343704d7..ca91553caa7dc741c01f304874818efe7d393eb3 100755 (executable)
@@ -21,6 +21,33 @@ zenity --info $icon_opt --title="NeuroDebian Setup Wizard" \
        --text="Welcome to the NeuroDebian virtual machine!
 
 This is the first time you have started this virtual machine. We will now perform a few simple steps to finalize its configuration. This includes upgrading the system to the latest available versions and installing additional software packages upon your request."
+
+# install custom filter for synaptics
+sudo mkdir -p /root/.synaptic
+sudo cat << EOT >> /root/.synaptic/filters
+filter "NeuroDebian" {
+  section {
+    inclusive false;
+    sections {
+    };
+  };
+  status {
+    flags 0x1ffff;
+  };
+  pattern {
+    andMode 0;
+    patterns {
+      Origin; "neuro.debian.net"; false;
+      Maintainer; "team@neuro.debian.net"; false;
+    };
+  };
+  priority {
+  };
+  reducedview {
+    enabled false;
+  };
+};
+EOT
 fi
 
 if ! zenity --question $icon_opt --title="NeuroDebian Setup Wizard" \