]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
Fixed a typo in the fhs build section of the rules file
authorManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:08:23 +0000 (05:08 +0000)
committerManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:08:23 +0000 (05:08 +0000)
Author: srivasta
Date: 2000/07/30 23:32:10
Fixed a typo in the fhs build section of the rules file

git-archimport-id: srivasta@debian.org--etch/debian-policy--devel--3.0--patch-60

debian/rules

index 1969428dbc6ffbbdf90ee4fb003b62b9488df110..59c351f690744f8623657f908b004e44751c0276 100755 (executable)
@@ -83,6 +83,8 @@ install_file   = /usr/bin/install -p  -o root -g root  -m  644
 install_program= /usr/bin/install -p   -o root -g root  -m  755
 make_directory = /usr/bin/install -p -d -o root -g root         -m  755
 
+GROFF_VERSION := $(shell dpkg -s groff | sed -n -e 's/Version: //p')
+
 
 all build: stamp-build
 stamp-build:
@@ -98,8 +100,7 @@ stamp-build:
        tar zfx $(FHS_ARCHIVE)
        # Need to use a patched tmac.m macro file if we're using a pre-1.16
        # groff; version 1.16 is apparently fixed
-       if [ dpkg --compare-versions \
-           `dpkg -s groff | sed -n -e 's/Version: //p'` lt 1.16 ]; then \
+       if dpkg --compare-versions $(GROFF_VERSION) lt 1.16; then \
            cp /usr/share/groff/tmac/tmac.m fhs && \
            cd fhs && patch -p1 < ../mm1.32-patch; \
        fi