]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge pull request #11 from yarikoptic/newdesign
authorMichael Hanke <michael.hanke@gmail.com>
Mon, 22 Apr 2013 18:43:28 +0000 (11:43 -0700)
committerMichael Hanke <michael.hanke@gmail.com>
Mon, 22 Apr 2013 18:43:28 +0000 (11:43 -0700)
Added quantal, removed EOL'ed Ubuntus, added mirrors for Debian and Ubuntu

Makefile
neurodebian_repo.cfg
sphinx/_templates/layout.html
sphinx/index.rst

index a2061681f261f5193fd74a3a805186d76c63fae7..4ae1d87989cd9a5f0f1b0a19676bdba6ce3d4a80 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,9 +52,10 @@ source-stamp:
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
-
-updatedb:
+cachefiles:
        $(BIGMESS) cachefiles -f
+
+updatedb: cachefiles
        $(BIGMESS) updatedb
        -rm source-stamp
 
@@ -78,5 +79,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon
 
index 409db0f515b84cc481a73c83705fcea403d9ef28..5c376aea944955c97193e664be1ae81979cfee42 100644 (file)
@@ -27,16 +27,21 @@ us-tn = USA-TN (Vanderbilt)
 # Package info files for all these releases will be downloaded.
 data = http://neuro.debian.net/debian/dists/data/Release
 hardy = http://neuro.debian.net/debian/dists/hardy/Release
-karmic = http://neuro.debian.net/debian/dists/karmic/Release
+#EOL karmic = http://neuro.debian.net/debian/dists/karmic/Release
 lucid = http://neuro.debian.net/debian/dists/lucid/Release
-maverick = http://neuro.debian.net/debian/dists/maverick/Release
-natty = http://neuro.debian.net/debian/dists/natty/Release
+#EOL maverick = http://neuro.debian.net/debian/dists/maverick/Release
+#EOL natty = http://neuro.debian.net/debian/dists/natty/Release
 oneiric = http://neuro.debian.net/debian/dists/oneiric/Release
 precise = http://neuro.debian.net/debian/dists/precise/Release
+quantal = http://neuro.debian.net/debian/dists/quantal/Release
 squeeze = http://neuro.debian.net/debian/dists/squeeze/Release
 wheezy = http://neuro.debian.net/debian/dists/wheezy/Release
 sid = http://neuro.debian.net/debian/dists/sid/Release
 
+[release bases]
+debian = http://amd64-geomirror.debian.net/debian
+ubuntu = http://de.archive.ubuntu.com/ubuntu
+
 [task files]
 datasets = http://anonscm.debian.org/gitweb/?p=pkg-exppsy/neurodebian-blend.git;a=blob_plain;f=tasks/datasets
 distributedcomputing = http://anonscm.debian.org/gitweb/?p=pkg-exppsy/neurodebian-blend.git;a=blob_plain;f=tasks/distributedcomputing
@@ -54,7 +59,7 @@ psychophysics = http://anonscm.debian.org/gitweb/?p=pkg-exppsy/neurodebian-blend
 # the 'data' entry should not be changed, as this exact setting also serves as
 # a test condition in the DDE code
 data = Datasets (data)
-#etch = Debian GNU/Linux 4.0 (etch)
+etch = Debian GNU/Linux 4.0 (etch)
 lenny = Debian GNU/Linux 5.0 (lenny)
 squeeze = Debian GNU/Linux 6.0 (squeeze)
 wheezy = Debian testing (wheezy)
@@ -62,7 +67,7 @@ sid = Debian unstable (sid)
 # EOL: May 12 2011 (Desktop) April 2013 (Server)
 hardy = Ubuntu 08.04 LTS "Hardy Heron" (hardy)
 # EOL: Oct 23 2010
-#jaunty = Ubuntu 09.04 "Jaunty Jackalope" (jaunty)
+jaunty = Ubuntu 09.04 "Jaunty Jackalope" (jaunty)
 # EOL: April 2011
 karmic = Ubuntu 09.10 "Karmic Koala" (karmic)
 # EOL: April 2013 (Desktop) April 2015 (Server)
@@ -75,6 +80,8 @@ natty = Ubuntu 11.04 "Natty Narwhal" (natty)
 oneiric = Ubuntu 11.10 "Oneiric Ocelot" (oneiric)
 # EOL: April 2017 (LTS)
 precise = Ubuntu 12.04 LTS "Precise Pangolin" (precise)
+# EOL: April 2014
+quantal = Ubuntu 12.10 "Quantal Quetzal" (quantal)
 
 [metadata]
 # base url: <url>/<src_pkg-name>/<file>
index 8dc01ce0dd5dc54d91e7fa3eed435577fcdca570..df859a9fcaea4c7d613ad4fa2d235b02066d0d5a 100644 (file)
@@ -18,7 +18,7 @@
   <li><a href="http://www.debian.org" target="_blank"><img border="0" src="/_static/debian.png" title="Visit debian.org" /><br />Debian</a></li>
  <li><a href="{{ pathto('index') }}"><img border="0" src="/_static/neurodebian.png" title="Go to the home page" /><br />Home</a></li>
  <li><a href="{{ pathto('pkgs') }}"><img border="0" src="/_static/package.png" title="List of available software" /><br />Software</a></li>
- <li><a href="{{ pathto('pkglists/toc_pkgs_for_suite_data') }}"><img border="0" src="/_static/datasets.png" title="List of available datasets" /><br />Data</a></li>
+ <li><a href="{{ pathto('pkglists/toc_pkgs_for_release_data') }}"><img border="0" src="/_static/datasets.png" title="List of available datasets" /><br />Data</a></li>
  <li><a href="{{ pathto('vm') }}"><img border="0" src="/_static/machine.png" title="Get NeuroDebian for your non-Debian computer" /><br />VM</a></li>
  <li><a href="{{ pathto('projects') }}"><img border="0" src="/_static/workarea.png" title="Current and planned projects: Get involved!" /><br />Contribute</a></li>
  <li><a href="{{ pathto('derivatives') }}"><img border="0" src="/_static/derivatives.png" title="Projects that use NeuroDebian as a foundation" /><br />Derived</a></li>
index 04407f6497011811cb142b5e883430192f14706f..47af87d6aa4c76fd36e5d23339aaf5580753e0f8 100644 (file)
@@ -95,7 +95,7 @@ News
 
 * **Services**
 * :ref:`Software <pkg_tocs>`
-* :ref:`Data <toc_pkgs_for_suite_data>`
+* :ref:`Data <toc_pkgs_for_release_data>`
 * :ref:`Appliance <chap_vm>`
 
 .. start a new list