]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge remote-tracking branch 'neurohydra/master'
authorYaroslav Halchenko <debian@onerussian.com>
Thu, 27 Oct 2011 22:22:37 +0000 (18:22 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Thu, 27 Oct 2011 22:22:37 +0000 (18:22 -0400)
* neurohydra/master:
  NH: little helper to initiate chroots for all supported distros
  BF: time into recommends since used in nd_ scripts
  BF: call apt-key add explicitly for older Ubuntus
  reordered dists by age to match Debian ones order
  RF: only suggest virtualbox-ose while installing neurodebian-dev

cmdsettings.sh
debian/control
tools/nd_adddist
tools/nd_adddistall [new file with mode: 0755]

index 037d3e19816783818413349aa67bc9e16cc795f5..3c1041423b678a1dc337307b539c30f879bc2f8c 100644 (file)
@@ -7,7 +7,7 @@ buildplace="${cowbuilderroot}/build"
 
 # all cuurently supported dists
 allnddists="nd+debian-lenny nd+debian-squeeze nd+debian-wheezy nd+debian-sid \
-            nd+ubuntu-oneiric nd+ubuntu-natty nd+ubuntu-maverick nd+ubuntu-lucid nd+ubuntu-karmic nd+ubuntu-hardy"
+            nd+ubuntu-hardy nd+ubuntu-karmic nd+ubuntu-lucid nd+ubuntu-maverick nd+ubuntu-natty nd+ubuntu-oneiric"
 alldists="$allnddists debian-lenny debian-squeeze debian-wheezy debian-sid"
 
 # default is debian
index 746ea0d4eb4a9e6ab843205c13da9f6389df0e24..4456894f66e759a5afb4dc4c829df895ef052f4f 100644 (file)
@@ -14,7 +14,8 @@ XS-DM-Upload-Allowed: yes
 Package: neurodebian-dev
 Architecture: all
 Depends: ${misc:Depends}, devscripts, cowbuilder, python, neurodebian-keyring
-Recommends: virtualbox-ose, virtualbox-ose-fuse, zerofree, moreutils
+Recommends: zerofree, moreutils, time
+Suggests: virtualbox-ose, virtualbox-ose-fuse
 Suggests:
 Description: NeuroDebian development tools
  neuro.debian.net sphinx website sources and development tools used by
index f5aa64d6d5ce3f9727f36f2b1b42efb6de2c0783..04f281246969047faaa4748fa0a7acd935f19765 100755 (executable)
@@ -42,9 +42,17 @@ for a in i386 amd64; do
                --mirror "$mirror" \
                --debootstrapopts --arch=$a \
                --othermirror "deb http://neuro.debian.net/debian $dist main contrib non-free"
-       # deploy our key manually since archive with package is not yet
-       # available at this point
-       cp --preserve=mode {,${cow}}/etc/apt/trusted.gpg.d/neurodebian-archive-keyring.gpg
+    # deploy our key manually since archive with package is not yet
+    # available at this point
+    mkdir -p ${cow}/etc/apt/trusted.gpg.d
+    cp --preserve=mode {,${cow}}/etc/apt/trusted.gpg.d/neurodebian-archive-keyring.gpg
+    # Old ubuntus might not have capability to ready from that key yet,
+    # so we would need to manually add it
+    if [ $dist = 'karmic' ] || [ $dist = 'hardy' ]; then
+        chroot ${cow} bash -c "apt-get install -y --force-yes gnupg \
+        && /usr/bin/apt-key add /etc/apt/trusted.gpg.d/neurodebian-archive-keyring.gpg \
+        && /usr/bin/apt-get update"
+    fi
   else
     cowbuilder --create --basepath ${cow} $opts \
                --components "$components" \
diff --git a/tools/nd_adddistall b/tools/nd_adddistall
new file mode 100755 (executable)
index 0000000..f01fa88
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/bash
+# Little helper to bootstrap all ND chroots as specified in
+# /etc/neurodebian/cmdsettings.sh unless a list provided in command line
+
+. /etc/neurodebian/cmdsettings.sh
+
+[ -z "$@" ] && dists="$allnddists" || dists="$@"
+
+echo "Initiating creation of chroots for $dists"
+
+set -eu
+
+CMD=
+MSGS="SUMMARY:\n"
+for dist in $dists; do
+        if [ -e "$cowbuilderroot/cow/$dist-amd64.cow" ]; then
+                status=exists
+        else
+                $CMD sudo $PWD/nd_adddist ${dist%%-*} ${dist#*-} && status=ok || status=failed
+        fi
+        MSGS+=" $(printf '%-30s\\t%s' $dist $status)\n"
+done
+echo -en $MSGS
+