]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Interactive subscription stats plot.
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 1 May 2013 08:06:20 +0000 (10:06 +0200)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 1 May 2013 08:06:20 +0000 (10:06 +0200)
.gitmodules
3rd/nvd3 [new submodule]
Makefile
sphinx/popularity.rst

index 5fd882ec613b81bf8b3773c035d25025ddd4ceec..6fd18423780178ed235ffc3656030f74524f0760 100644 (file)
@@ -4,3 +4,6 @@
 [submodule "3rd/bigmess"]
        path = 3rd/bigmess
        url = git://github.com/neurodebian/bigmess.git
+[submodule "3rd/nvd3"]
+       path = 3rd/nvd3
+       url = git://github.com/novus/nvd3.git
diff --git a/3rd/nvd3 b/3rd/nvd3
new file mode 160000 (submodule)
index 0000000..7e9b8c0
--- /dev/null
+++ b/3rd/nvd3
@@ -0,0 +1 @@
+Subproject commit 7e9b8c013c4d8e8ad5775062c438c842bc112585
index de232c7f9ba364e6fdb7691eb0ad89497e3be0b1..73f0ab7d87a1e9229200ae51bc8a1b7080ee67fa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -51,11 +51,15 @@ source: source-stamp
 source-stamp: 
        mkdir -p build/src/pkgs/
        mkdir -p build/src/lists/
+       mkdir -p build/src/_static/
        mkdir -p build/src/pkglists/
        $(BIGMESS) mkpkgs  -d build/src/pkgs/
        $(BIGMESS) mkaptcfgs -d build/src/lists/
        $(BIGMESS) mkrepocfg > build/src/sources_lists
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
+       cp 3rd/nvd3/*.min.js build/src/_static/
+       cp 3rd/nvd3/lib/d3*.min.js build/src/_static/
+       cp 3rd/nvd3/src/nv*.css build/src/_static/
        touch $@
 
 cachefiles:
index 1ad932590e5e3c0bed73331ce4a67a68ce45a577..da24bc20c00fb7a69d26d7bea4da7236f54f8797 100644 (file)
@@ -10,9 +10,24 @@ Popularity Statistics
 Repository subscriptions
 ========================
 
+Interactive visualization of new NeuroDebian repository subscriptions. Plotted
+are each week's average number of daily subscriptions for all Debian and Ubuntu
+releases. Statistics for individual releases can be compared by clicking on the
+respective curves and labels in the legend.
+
+Note that each machine only needs to be subcribed to the repository, and only
+subscriptions done via the website are counted.
+
+
 .. raw:: html
 
- <p><img border="0" src="_files/nd_subscriptionstats.png" title="Statistics of new repository subscriptions for all supported releases. Note: subscription is only done once per machine." /></p>
+  <link href="/_static/nv.d3.css" rel="stylesheet" type="text/css">
+  <div><svg style="height:500px" id="subscriptionchart"></svg></div>
+
+  <script src="/_static/d3.v2.min.js"></script>
+  <script src="/_static/nv.d3.min.js"></script>
+  <script src="/_static/subscriptionchart.js"></script>
+
 
 Popularity Contest
 ==================