]> git.donarmstrong.com Git - neurodebian.git/commitdiff
RF+NF: deploy neurodebian apt key for nd+ cows
authorYaroslav Halchenko <debian@onerussian.com>
Sat, 30 Oct 2010 16:39:12 +0000 (12:39 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Sat, 30 Oct 2010 16:39:12 +0000 (12:39 -0400)
debian/control
tools/nd_adddist

index 9917fe214ac2cecefc8317055c396c5f9dfb659a..f8014a777c9372068d356f21927f14e23a68c14a 100644 (file)
@@ -13,7 +13,7 @@ XS-DM-Upload-Allowed: yes
 
 Package: neurodebian-dev
 Architecture: all
-Depends: ${misc:Depends}, devscripts, cowbuilder, python
+Depends: ${misc:Depends}, devscripts, cowbuilder, python, neurodebian-keyring
 Recommends: virtualbox-ose, virtualbox-ose-fuse, zerofree
 Suggests:
 Description: NeuroDebian development tools
index 065173d98c6e115752d4539d2750baa9e75b3b41..94bd35b146afbe1c82e97634c2adf9adb123779a 100755 (executable)
@@ -21,22 +21,27 @@ fi
 # common options
 opts="--distribution $dist --debootstrap debootstrap --aptcache $aptcache"
 
+mkdir -p ${cowbuilderroot}/cow
 
 for a in i386 amd64; do
   echo "Building $a base path..."
-  if [ -d ${cowbuilderroot}/cow/${family}-${dist}-${a}.cow ]; then
-    echo "${cowbuilderroot}/cow/${family}-${dist}-${a}.cow exists. Ignoring arch."
+  cow="${cowbuilderroot}/cow/${family}-${dist}-${a}.cow"
+  if [ -d "$cow" ]; then
+    echo "${cow} exists. Ignoring arch."
     continue
   fi
   if [ "${family:0:3}" = "nd+" ]; then
   echo "Including NeuroDebian repository..."
-    cowbuilder --create --basepath ${cowbuilderroot}/cow/${family}-${dist}-${a}.cow $opts \
+    cowbuilder --create --basepath ${cow} $opts \
                --components "$components" \
                --mirror "$mirror" \
                --debootstrapopts --arch --debootstrapopts $a \
                --othermirror "deb http://neuro.debian.net/debian $dist main contrib non-free"
+       # deploy our key manually since archive with package is not yet
+       # available at this point
+       cp --preserve=mode {,${cow}}/etc/apt/trusted.gpg.d/neurodebian-archive-keyring.gpg
   else
-    cowbuilder --create --basepath ${cowbuilderroot}/cow/${family}-${dist}-${a}.cow $opts \
+    cowbuilder --create --basepath ${cow} $opts \
                --components "$components" \
                --mirror "$mirror" \
                --debootstrapopts --arch --debootstrapopts $a