]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Few more touches
authorMichael Hanke <michael.hanke@gmail.com>
Thu, 4 Nov 2010 01:09:48 +0000 (21:09 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Thu, 4 Nov 2010 01:09:48 +0000 (21:09 -0400)
debian/changelog
tools/nd-vmsetupwizard
tools/nd_compactvdi
tools/nd_setupguestos

index 61adb78e88975e0687525edfecb7112a36e36859..8ccbc2643b7dd2660c845f2e54f2f85bd3708bab 100644 (file)
@@ -1,5 +1,5 @@
-neurodebian (0.13) squeeze; urgency=low
+neurodebian (0.14) squeeze; urgency=low
 
   * Initial release.
 
- -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 17:29:11 -0400
+ -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 21:09:32 -0400
index 99ae8f93b93a00ca77eb1915b691884574c8512a..539fb350a09c0afc2f8af42ec984c5cca219d37c 100755 (executable)
@@ -24,7 +24,7 @@ This is the first time you have started this virtual machine. We will now perfor
 fi
 
 if ! zenity --question $icon_opt --title="NeuroDebian Setup Wizard" \
---text="The setup procedure requires network access to download packages from the Debian archive. If you do not have network access right now, you can re-start this wizard at any time from the NeuroDebian menu.
+--text="The setup procedure requires network access to download packages from the Debian archive. If you do not have network access right now, you can re-start this wizard at any time from the NeuroDebian menu. If you proceed you may have to enter the superuser password with is by default 'neurodebian'.
 
 Do you want to proceed with updating the system?
 "; then
index 0c0c8ab6e1486406c2faf94001d498cb971a3eca..bdd4112e3bcfa45468676306c1d4010ce7297ee1 100755 (executable)
@@ -38,9 +38,11 @@ find vbmnt/var/log -type f -delete
 # apt lists
 find vbmnt/var/lib/apt -type f -name '*debian*' -o -type f -name '*list*' -delete
 # user data
+# cannot clean all root stuff, because it also contains useful thing (e.g. git setup)
+#find vbmnt/root -mindepth 1 -delete
 rm -f vbmnt/root/.*history
 # everything for the default user
-#find vbmnt/home/brain -mindepth 1 -delete
+find vbmnt/home/brain -mindepth 1 -delete
 
 # unmount filesystem
 umount vbmnt
index 0c8c8ee397a2d335c95636fb201403513d0dff30..f14fb1190cabafeff5a076e46179ce0f9c1cebcb 100644 (file)
@@ -55,6 +55,8 @@ apt-get update
 apt-get install neurodebian-keyring
 apt-get update
 
+# to cheat the VM check
+touch /dev/vboxguest
 # to get all the stuff in recommends
 apt-get install dkms neurodebian-guest-additions
 
@@ -69,6 +71,7 @@ find /var/cache/apt/archives/ -name '*.deb' -delete
 # cleanup unwanted stuff
 # video drivers (all but vesa)
 apt-get purge $(apt-cache search --names-only --installed xserver-xorg-video | grep xserver-xorg-video | cut -d ' ' -f 1,1) xserver-xorg-video-vesa+
+apt-get purge brasero
 
 # and whatever is obsolete
 apt-get autoremove --purge
@@ -81,4 +84,8 @@ sed -i -e 's,http://www.debian.org,http://neuro.debian.net,g' /etc/chromium-brow
 sed -i -e 's/GRUB_TIMEOUT=5/GRUB_TIMEOUT=1/g' /etc/default/grub
 update-grub
 
+# finally configure geomirror for APT and disable deb-src lists
+sed -i -e "s/10.0.0.1:9999/$(dpkg --print-architecture)-geomirror.debian.net/" \
+    -e "s/^deb-src/#deb-src/" /etc/apt/sources.list
 
+etckeeper commit "Initial VM setup done"