]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge remote branch 'alioth/master' into enh/wheezy-vm
authorYaroslav Halchenko <debian@onerussian.com>
Tue, 18 Dec 2012 17:50:30 +0000 (12:50 -0500)
committerYaroslav Halchenko <debian@onerussian.com>
Tue, 18 Dec 2012 17:50:30 +0000 (12:50 -0500)
* alioth/master:
  BF: move -u in nd_build down so we get sensible help
  exclude debian-devel from being wipedout upon upload-website

Makefile
tools/nd_backport

index f2876a1740f680b4cc18d330e4c647d5eb39eb55..8aa19e3d4f1c01885068669e8b754efa488aa93b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ build/db.db:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp
index b71fe5d6ba0b3f9b23cf5f89ccfb47603e3dea12..b91b54a3d54e60780ed9b73de1b3286e71256d4f 100755 (executable)
@@ -4,7 +4,6 @@
 #
 
 set -e
-set -u
 
 release=$1
 dscfile=$2
@@ -27,6 +26,8 @@ EOT
 exit 1
 fi
 
+set -u
+
 upstream_name=${dscfile%%_*}
 
 # To overcome bash desire to claim empty array unbound under 'set -u'