]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
a bit more sane handling of odd cases
authorManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:34:29 +0000 (05:34 +0000)
committerManoj Srivastava <srivasta@debian.org>
Thu, 16 Jun 2005 05:34:29 +0000 (05:34 +0000)
Author: joy
Date: 2002/11/15 02:13:41
a bit more sane handling of odd cases

git-archimport-id: srivasta@debian.org--etch/debian-policy--devel--3.0--patch-151

debian/rules

index 450b4a3bffc54286cd103d13cfe2142b169a5704..7a9aa99145d589a3b3f7a49f2f80f28c8e200492 100755 (executable)
@@ -98,14 +98,14 @@ stamp-build:
          debiandoc2html $$file.sgml; \
          debiandoc2text $$file.sgml; \
          if [ -f $$file.text ]; then mv $$file.text $$file.txt; fi; \
-         gzip -9 $$file.txt; \
+         gzip -f9 $$file.txt; \
          tar -cf $$file.html.tar $$file.html; \
-         gzip -9 $$file.html.tar; \
+         gzip -f9 $$file.html.tar; \
        done
        tar -zxf $(FHS_ARCHIVE)
        # Need to use a patched tmac.m macro file if we're using a pre-1.16
        # groff; version 1.16 is apparently fixed
-       if dpkg --compare-versions $(GROFF_VERSION) lt 1.16; then \
+       if dpkg --compare-versions "$(GROFF_VERSION)" lt 1.16; then \
            cp /usr/share/groff/tmac/tmac.m fhs && \
            cd fhs && patch -p1 < ../mm1.32-patch; \
        fi
@@ -168,7 +168,7 @@ stamp-policy:  build
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
        # Be more specific with file compression
-       -gzip -9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
+       gzip -f9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
                                $(DOCDIR)/fhs/* $(DOCDIR)/changelog
        $(install_file)     debian/copyright         $(DOCDIR)/
        GZIP=-9 cd debconf_spec && \