]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Allow for custom title; charge "tasklist"
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:05:33 +0000 (16:05 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:14:41 +0000 (16:14 -0400)
debian/changelog
tools/nd-autoinstall
tools/nd-vmsetupwizard

index c3010419129e00cb53a0147c3f1c798fef85071b..80746411b8abb7ef9795604f281778371c73b369 100644 (file)
@@ -1,5 +1,5 @@
-neurodebian (0.6) squeeze; urgency=low
+neurodebian (0.8) squeeze; urgency=low
 
   * Initial release.
 
- -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 14:41:15 -0400
+ -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 16:11:48 -0400
index 8ea12539c3ad316750519582dcc0d04ed0fe0a3f..66bcdb109ada3b428e41e60cec21fee425c13034 100755 (executable)
@@ -16,6 +16,7 @@ nd_autoinstall_version=0.1
 ai_envfile=
 ai_package=
 ai_verbose=
+ai_dialog_title=
 ai_force=0
 
 print_verbose()
@@ -67,6 +68,9 @@ Options:
   -v, --verbose
     Enable additional progress messages.
 
+  -t, --title
+    Optinal title of the installation dialog.
+
   -h, --help
     Print short description, usage summary and option list.
 
@@ -90,7 +94,7 @@ EOT
 # Note that we use `"$@"' to let each command-line parameter expand to a
 # separate word. The quotes around `$@' are essential!
 # We need CLOPTS as the `eval set --' would nuke the return value of getopt.
-CLOPTS=`getopt -o h,e:,p:,f,v --long help,version,environment-file:,package:,verbose,force -n 'nd-autoinstall' -- "$@"`
+CLOPTS=`getopt -o h,e:,p:,t:,f,v --long help,version,environment-file:,package:,title:,verbose,force -n 'nd-autoinstall' -- "$@"`
 
 if [ $? != 0 ] ; then
   echo "Terminating..." >&2
@@ -105,6 +109,7 @@ while true ; do
          -e|--environment-file) shift; ai_envfile=$1; shift;;
          -f|--force) ai_force=1; shift;;
          -p|--package) shift; ai_package=$1; shift;;
+         -t|--title) shift; ai_dialog_title=$1; shift;;
          -v|--verbose) ai_verbose=1; shift;;
          -h|--help) print_help; exit 0;;
          --version) print_version; exit 0;;
@@ -122,6 +127,8 @@ fi
 ai_command=$1; shift
 [ -z "$ai_package" ] && ai_package=$ai_command
 
+[ -z "$ai_dialog_title" ] && ai_dialog_title="Package installation"
+
 ai_envfile_failed=
 if [ ! -z "$ai_envfile" ]; then
        source "$ai_envfile" || ai_envfile_failed=1
@@ -156,7 +163,7 @@ if [ $do_install -eq 1 ]; then
                DEBIAN_FRONTEND=gnome /usr/bin/apt-get install -y $ai_package 2>&1 \
         && rm -f $logfile; } \
         | tee $logfile \
-        | zenity --title="Package installation" \
+        | zenity --title="$ai_dialog_title" \
                         --text="Installing $ai_package" \
                  --progress --pulsate --auto-close --auto-kill
     if [ -e $logfile ] ; then
index 792f431f05ca515688b0f942b33d97c4c00abb90..1927bd304395822d4ee9f4e698bedfb0343704d7 100755 (executable)
@@ -52,14 +52,23 @@ fi
 
 packages=$(zenity --list --checklist --column="Install" --column="Description" \
           --column="Package Name" --print-column=3 --hide-column=3 --hide-header \
-          --separator=' ' --text="This is the manual
-" \
-FALSE "one" "ipython" \
-FALSE "two" "vim" \
-FALSE "three" "bc dc" || true)
+          --separator=' ' --text="Please select any additional component that shall be installed.
+
+Please note that this selection will not affect packages already installed
+on the system. No installed packages will be reinstalled or removed, only
+additional components will be installed." \
+FALSE "Emacs" "emacs" \
+FALSE "OpenOffice.org" "openoffice.org" \
+FALSE "Scientific Python" "ipython,python-numpy,python-matplotlib" \
+FALSE "TeX Live" "texlive" \
+FALSE "Adobe Flash browser plugin" "flashplugin-nonfree" \
+FALSE "Sun Java browser plugin" "sun-java6-plugin" \
+|| true)
 
 if [ -n "$packages" ]; then
-       nd-autoinstall -f -p "$packages" true
+       for pkgs in $packages; do
+               nd-autoinstall -f -p "${pkgs//,/ }" true
+       done
 fi
 
 # and start greeter