]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Few fixes.
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 18:41:26 +0000 (14:41 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 18:41:26 +0000 (14:41 -0400)
debian/changelog
tools/nd-vmsetupwizard

index a84338620d2275115b53d46533d96815213c0e48..c3010419129e00cb53a0147c3f1c798fef85071b 100644 (file)
@@ -1,5 +1,5 @@
-neurodebian (0.5) squeeze; urgency=low
+neurodebian (0.6) squeeze; urgency=low
 
   * Initial release.
 
- -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 14:31:48 -0400
+ -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 14:41:15 -0400
index 03900eedb413e498a3e62ae4330cfdf722cf69ab..792f431f05ca515688b0f942b33d97c4c00abb90 100755 (executable)
@@ -6,7 +6,8 @@
 set -e
 set -u
 
-success_flag=/etc/neurodebian/guest/setupwizard_done
+cfg_dir=/etc/neurodebian/guest/setupwizard_done
+success_flag=$cfg_dir/setupwizard_done
 nd_icon=/usr/share/pixmaps/neurodebian.svg
 icon_opt="--window-icon=$nd_icon"
 
@@ -23,7 +24,7 @@ This is the first time you have started this virtual machine. We will now perfor
 fi
 
 if ! zenity --question $icon_opt --title="NeuroDebian Setup Wizard" \
---text="The setup procedure requires network access to download packages from the Debian archive. If you do not have network access right now, you can re-start this wizzard at any time from the NeuroDebian menu.
+--text="The setup procedure requires network access to download packages from the Debian archive. If you do not have network access right now, you can re-start this wizard at any time from the NeuroDebian menu.
 
 Do you want to proceed with updating the system?
 "; then
@@ -31,7 +32,7 @@ Do you want to proceed with updating the system?
 fi
 
 # initialize apt
-#update-manager -c
+update-manager -c
 
 if [ ! -e /etc/popularity-contest.conf ]; then
        zenity --info $icon_opt --title="NeuroDebian Setup Wizard" \
@@ -46,7 +47,7 @@ fi
 
 # essential things are done -- let's mark sucess
 if [ $first_run -eq 1 ]; then
-       sudo touch $success_flag
+       sudo bash -c "mkdir -p $cfg_dir && touch $success_flag"
 fi
 
 packages=$(zenity --list --checklist --column="Install" --column="Description" \
@@ -55,7 +56,7 @@ packages=$(zenity --list --checklist --column="Install" --column="Description" \
 " \
 FALSE "one" "ipython" \
 FALSE "two" "vim" \
-FALSE "three" "bc dc")
+FALSE "three" "bc dc" || true)
 
 if [ -n "$packages" ]; then
        nd-autoinstall -f -p "$packages" true