]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge branch 'master' of git.debian.org:/git/pkg-exppsy/neurodebian
authorMichael Hanke <michael.hanke@gmail.com>
Tue, 27 Sep 2011 09:20:51 +0000 (11:20 +0200)
committerMichael Hanke <michael.hanke@gmail.com>
Tue, 27 Sep 2011 09:20:51 +0000 (11:20 +0200)
* 'master' of git.debian.org:/git/pkg-exppsy/neurodebian:
  ENH: new target upload-website-stamp

Makefile

index 2d6b52360da01300509df06dc7a325e548219dc5..4b9e35a7c432e465bdc0be57ec29b89b60395f49 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ html: pics source
 
 
 clean:
-       -rm html-stamp source-stamp
+       -rm html-stamp source-stamp upload-website-stamp
        $(MAKE) -C artwork clean
 
 
@@ -64,6 +64,12 @@ upload-website: html
        rsync -rvzlhp --delete \
         --exclude=debian --exclude=debian-local --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       : # Touch stamp here so we get it updated on every upload
+       touch $@-stamp
+
+# call upload iff .git/index was modified, i.e. new changes got pulled in
+upload-website-stamp: .git/index
+       $(MAKE) upload-website
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html